Gear S3 AOD Turning Off Screen When Using Facer

Hello, I’m hoping someone might be able to point me in the right direction on this odd issue. The AOD on my Gear S3, after it goes into dim mode, will totally turn off the screen after a few seconds. I DO see the dimmed/alternate screen for a few seconds before the watch screen turns off.

The kicker is, not only is this problem isolated to Facer, it’s isolated to a watch face that I created but never had problems with until recently. In fact, I’ve not made any updates to the face in years before today. All other Samsung faces and Facer faces work fine–when dimmed, they stay in dim mode and the screen does not turn off.

This is the face I made that I’m having trouble with:

I’ve so far:
Fully reset my watch, uninstalling the Gear Plugin and reinstalling, setting everything back up.
Uninstalled the Facer app and the watch companion app, reinstalling both.
Confirmed no special power modes (like Theater Mode) are enabled.
My watch screen is set to timeout after 10 seconds. Changing this value higher or lower does not affect the problem.
I’ve made minor updates to the face, saving the changes, removing and re-syncing the face.
The Facer app and companion app, along with the watch software are all up to date.
Using a Samsung S21+ which I’ve had now for a long time.

For the life of me, I can’t figure this out. The face doesn’t go all black (or turn off the screen) every time I turn my wrist back–sometimes the dimmed screen for the face does stay on like it’s supposed to. More often than not though, the dimmed mode will only show for a few seconds before the screen goes totally black. Again, zero problems with other Facer faces (and Samsung faces).

Any suggestions or insight is greatly appreciated at this point!

Thank you for taking the time to read this in advance!

That’s weird. Try this, in the DIM mode layers in the Creator, turn off all of your layers visibility. Then add an image on a layer at the top. See if that stays up in DIM mode.

Thank you for your reply! I tried that with no luck unfortunately. I had to originally add another Element/Image to the Dim mode in order to have the same background image in both Dim and Active modes. That image is hidden in active mode, and only visible in dim mode. My screen still turned off after disabling all other layers.


man thats weird, maybe turn inspection on so we can dig in there?

Thanks I’d love for someone to check it out under the hood if possible! I’ve re-saved it a few times now with Inspector Mode enabled but I don’t see the option for it either?

Unless I’m missing something obvious? I’m making sure this is ticked when updating:


EDIT, just realized Inspector Mode is on but for some reason the rocket icon to the left of the watch doesn’t show in the link above. If I navigate to the watch’s actual webpage the rocket icon is there to go into Inspector Mode.

I’m at my wits end trying to figure this out!

I’ve done additional testing after making a testing copy and have isolated the problem to the “VHWatch.jpg” as seen above, located at the very top in Dim mode:

Seems if I disable the other 3 elements (digital time, temperature, and text layer) the image by itself works fine–the watch screen does not turn off in Dim mode.

If I add any other element with that image, the watch screen turns off in Dim mode (not always, but most of the time; this was/is the original problem).

If I remove that image, and have the other 3 elements active, the screen works fine and does not turn off in dim mode.

I’ve also tried uploading a different image as the background with the same results as above.

Again, what’s odd is this was never a problem until the last month or so. I made that face years ago and it worked fine up until recently.

Going to try and look at how others configure their Dim modes via Inspector. Maybe I was doing this wrong all along?

i just took a look, maybe its cause its set to 55% transparent? set it to 100 and see if it works

Thank you for taking a look! Unfortunately that didn’t work either. As soon as I enable one of the other elements the problem returns.

Well, I’m at a loss… I just built a brand new face from nothing, starting with a blank design. I then added each element mirroring all elements of my original face. Same problem: Dim Mode appears for a second or so before the screen turns completely off.

This problem doesn’t make any sense since it doesn’t occur with any other watch face, Facer or Samsung. At the same time, I can’t begin to understand why mine has this problem after working fine for years. Did something change that limits what we can display in Dim Mode?

I’m assuming if there was a problem with the Facer Companion I’d see this problem on any face, not just the one I made.

It sounds like you are butting heads with Samsungs watch programming to limit the number of pixels turned on in AOD mode. There is a threshold that once passed Tizen will throttle back the AOD mode. I’ve heard anywhere from 10% up to 35% and don’t really know what it is. I’ve heard it is also involving the colors used in AOD. I do know that the more turned on in a watchface is in AOD, the more Samsung’s watch OS throttles it.

Thanks very much for your reply and the info!

That makes a lot of sense as most other watch faces I have don’t have as much going on in dim mode as the one I made. Especially once you factor in the colors.

Wonder if that AOD pixel throttling was implemented in one of the recent updates for the watch. Bugs me because it worked perfect for years but if this is how it is then nothing I can do!

Thanks again!

I gave away my Gear S3 Frontier just because Facer quit working correctly on it. The colors were not being displayed correctly at times and Facer would become unstable after a few hours and crash. You can do a search here in the community above at the magnifying glass icon about the color problem. A fellow was asking about it late last year with his S3 and when I tried the watchface he had trouble with my S3 would not display the color correctly, but my Galaxy Watch 1st gen worked just fine. So it had to be a difference in the Tizen version between the two.

Huh. Good to know, thank you. This watch is a bit old now. I don’t think I’ve ever experienced those color issues. I’ll probably wait until this thing totally dies before getting another.

I’m playing around right now with my test copy of this face based on what you said above and having some luck. I’ll reply again if I get somewhere with it.

1 Like

@Rator and @mrantisocialguy

Thank you both for your help with this! I was finally able to fix it!

I had to drop the opacity of the Dim Mode image/wallpaper from 55% to 45%, and drop the opacity of the 5150 text in Dim mode from 100% to 70%.

The screen now stays on in Dim Mode. I played around with raising and lowering the opacities in 5% increments back and forth but once I reached a certain percent the problem returned.

Again, I GREATLY appreciate the help–thanks!

1 Like