Heart rate (#ZHR#) works with one watch but not with another (galaxy watch)

Hello community!
I created this watch face: DarkWatch - BIG & BOLD Interactive - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

(Look at the comments.) : We both have a samsung galaxy watch; on my watch everything works but for “Maj3sTiC-D” the heart rate does not work…

I’m using the #ZHR# tag (inspection mode is active)

I am new to Facer, it is my 1st “premium” watch face, my 1st “premium” download and my 1st comment … I would like him to be satisfied and be sure that everything works !!!
(if you sync it with your watch, tell me if it works for you.)

I would like to understand what is happening to him and find a solution to this bug, especially if the problem comes from my conception

Thanks for your help

I went and looked at your watch face using inspection mode. (thank you for leaving inspection turned on) And I see nothing that would cause a watch to not see the heart rate. Which makes me wonder if they have all the permissions granted for Facer to operate properly on their watch. Or even if they have the heart rate testing turned on in their watch. If I wasn’t a free user, I would sync it myself as a final test, but Facer won’t allow us non-paying users that privalage.

You can preview a premium watch face on your watch for limited time by holding the purchase button on the phone app

And I agree, would probably be a permission thing or something.

1 Like

They must have changed that function because I tried it just like you said, holding the purchase button for 20-30 seconds does nothing until I release it then it goes straight to the purchase Facer Premium page. Maybe it only works on Facer Partner faces that can be bought through the app. Oh well, I tried.

Thank you for your answers, I thought like you about the permissions … I never heard from this people and I had other downloads, no one else complained, he had the 'sure of himself though;)

About the free preview, it’s actually written under the button, I had never seen it so I tried and no it doesn’t really work … Me too it downloads the watch face to my watch but I can’t use it, it sends me back to the payment page on my phone too

Thanks for your answers anyway!