[Help] 1 Sec Animation Conditionals (with %) Broken Since Update

So I noticed today that every watchface I have created using a 1 second per frame conditional is no longer functioning on my watch:

For Reference:

Image 1 Opacity: $(#Ds#%4)=0.0?100:0$
Image 2 Opacity: $(#Ds#%4)=1.0?100:0$
Image 3 Opacity: $(#Ds#%4)=2.0?100:0$
Image 4 Opacity: $(#Ds#%4)=3.0?100:0$

$(#Ds#%[number of total frames])=[frame number]?100:0$

They look fine in the preview on the desktop site, but when I view them in my app or sync them to my watch the images with those tags have completed disappeared. This is true for every watchface I have created using the above conditional. Here is my blinking traffic signal for reference:

It looks perfectly fine there in the preview, but on the app and on my watch, none of the lights or info are blinking or even available. It’s just a blank, black traffic light.

Anyone have an idea of what could be the issue? I have tried completely uninstalling and re-installing Facer on both my phone and my watch. They worked just fine previously, but nothing seems to help now. I have the original Huawei if that helps.

Thank you.

1 Like

@ShaneAshleyA; nice face by the way
@Facer_Official; there seems to be a lot of bug issues being reported, think the latest update may have bugs that aren’t just Tizen based

I’d bet it’s the % function that’s not behaving in the same way as before. Your conditionals should work again if you switch them out for slightly longer expressions that use only division and the floor function:


Little Labs has been slammed with open bugs since the latest round of Samsung and Facer updates, so it's probably best to fix your watch faces without requiring any action on their end.

How might it look for 3 frames? I appreciate your help. I’m not a programmer or anything so some of these equations are like learning another language.