HELP - Watchface dissapeared?


Hi Guy’s,

I’ve just been editing all my faces and I seem to of misplaced one of my popular ones. It was called Revolution V-Twin. Is there anyway you can recover it. It took me some time to make as it was my training one. I’d be eternally grateful if you could do anything :frowning:

Ok, Scrap that, Just made it again. Revamped :slight_smile:

I dont understand, I just re-made it, called it Revolution V-Twin (VROD) this time and it appeared to upload and save, chose to goto my collection after and it isnt there, so now I know I never accidentally deleted it. It isnt anywhere to be seen. What’s going on fella’s.

Was really plesed with the new version too :frowning:

Any idea’s, will they come back later?

I have 2 versions of it somewhere now >>

  • Revolution V-Twin
  • Revolution V-Twin (VROD)

\so i went back on the browser and recovered this link >

This content was automatically removed due to suspected copyright/trademark infringement.

How did that happen. Its just an engine with a rev counter on it. Last one was popular and in circulation for ages. All i did with the old was add my Goatface logo and it got removed competely. then i remade it and same appears to of happened. I’d like to know if poss what the problem was so I can resolve it but you dont get the option to.

please advise ASAP

only person im in danger of copying i=was my own Adrenalin watch. i just duplicated that and added the engine. please help me reinstate, im confused.

Ok, Ignore the description cos its a dup of one of my others and wont get editied until I publish. So this is pretty much what I had before and what I rebuilt again today thats getting pulled down. Whats wrong with it >

I’d offer to help but at the moment my facer seems broke… There was an update for my Galaxy Watch and now Facer does nothing. I keep sending faces and not a single one goes thru now.

Its all good mate, I managed to build it again a couple of times and just renamed stuff til it uploaded. I’ve saved a dup of it this time though. Got there in the end. Same as you though I still cant use any of them lol

So you’re having sync issues today too after the update?? I know I had a similar issue when using Watchmaker. I made a watch that looked exactly like a rolex. but I altered the logo to say FOLEX instead. I NEVER got any notification but each time I tried to publish it I would go to the link and it would say nothing is there. I had the face up for a while and then suddenly after one update I made to it and tried to update it the face was gone from my profile and anytime I tried to re-upload w/ the same name it auto-deleted and wouldn’t post. The watch was named FOLEX and after switching the name to Matrix it uploaded fine and has remained in the Watchmaker gallery. It also inspired the Matrix watch I made w/ Facer.

1 Like

Yeah basically that mate, re-uploaded named slightly different. Ive learnt now though to dup them first :slight_smile: