I have Fossil Q explorist with Iphone xs - face is not changing(syncing)

I have fossil q gen 3 smart watch connected with Iphone xs. I tried connecting them both, I scan the QR code and it says connected. But when I select a new face, it says its sent to phone, but on the watch nothing happens.

Smart Watch:
OS: 2.1
Android OS 8.0.0
Model: Q Explorist (Fossil)

Iphone xs
version 12.1


Which watch face are you trying to sync? Is the button blue or orange?

I tried many of them, all free.
I even tried many from my favorites.

The color of the button is blue.

There seems to be a connection re-sync issue that I’ve found and I believe that Facer may be working on this.
If I understand you, the watch is connected to the iPhone (if you go to the phone Galaxy App it shows phone battery data indicating a connection).

I have found the same thing with iPhone 7/8 and now with the Xx Max as well.

If I send a face to the watch from the iphone and then disconnect/reconnect the watch (e.g. kill the Galaxy App on the phone and then restart it) the face will send to the watch when it re-syncs after the reconnect.

Not ideal, but will have to do for now until the sync issue is resolved.

I have a fossil watch not the Samsung watch.
Should I usu Samsung watch app to connect to fossil watch?

Hi @harnish.cool - no, you should be all fine, especially if the QR code was dismissed on the watch after you scanned it. Can you send us an email at facer-support@little-labs.com? We’ll investigate that with you!

I have the same phone, watch and issue. Was there ever a solution found?