Image sequencer single run

Hi all,

The image sequencer doesn’t show any of the images when not in loop mode and of course I want the sequence to run only once :slight_smile: Any suggestions?

Jean Pierre

@jean-pierre.verbesse I think your asking the same question discussed just the other day. See if this thread helps you :slight_smile:

Image sequencer

Thank you for replying, and yes I read this one but in my case only the first image in the sequence is shown… image 2 to 22 never appears. When I select loop than all goes well.

Ok I tried to replicate the problem and I think I spotted the issue.

The trigger defaults to On Sync. I switched it to On Wake and it started working. Changing it back to On Sync seems to work after doing this. Not sure if it’s related but try it and see if this fixes things.

When you have a image sequence to run once (not looping) you always have to chose start on wake. If you chose start on sync the image sequence just being played once and the first frame will show forever…

Thank you all for the input, but the problem is that the sequence only plays when loop is selected. Wether On wake or On sync is selected doesn’t seem to matter… the sequence isn’t been played when loop is off.I tried it several times… but no succes.

Strange, it worked for me when I tried.

Can you turn on inspection mode and link the watch by chance?

EDIT - How are you testing also? Timeline? Showcase?


This morning it works on showcase, but not in creator (having On wake selected)…
Here’s the link: Jean Pierre Verbesselt - Broken Too - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

In crearor almost never works. I scroll forward and back a couple time just to see one frame to make de design. You have to test the image sequences in your watch… In the facer app the on wake image sequences works fine but the on sync still doesnt work…

Thank you, it helps a bit, would prefer that it works like it should work :slight_smile:

Yeah, when I test it in creator, I have to click the play button, go up to the active/dim tab making sure not to hover over the layers or it stops “play mode” just to trigger the onWake animation.

It’s useful for things like hitting play and advancing the day/hour manually, but for things like testing weather, etc it can be a pain.

Anyways, it sounds like it’s working, just a pain.

Neat looking watch, btw!

Thanks for the tip! At least you can test it without going to the showcase mode. Now I just have to get rid of the first picture that comes up after the sequence is done. I read this in another topic but I don’t know yet how to move the picture out of the way after the sequence is finished.

The watch is just an idea I was playing with… just for fun.

could you not play with the opacity? so that as the sequence ends the picture would fade away?