Is anyone having problems with facer creator other than myself?

Today I am not able to edit any of my watchfaces. When I click on edit button it starts to load creator interface and it stucks with the progress bar animation forever, with no interface loaded in background.


Yeah, it’s been being really slow for me today. I have been able to edit, somewhat tediously, by reloading the page while it’s stuck on the state it’s in in your screenshot. Hopefully that works for you.

1 Like

You’re THE MAN, your solution worked immediately, thank you! It’s really sssllooooww but I can at least to correct something.

No problem :slight_smile:
Hopefully Facer sorts out their servers. They’re annoyingly slow.

just an update 11:33am 4/17:

(a) Creator very slow to load or can’t load
(b) Creator - cannot save - spins for hours.


meanwhile… the community face widget loads here in the discussions today are screaming fast. I just opened a post with something like 8 widgets. Loaded immediately

Last night I was working on an animation and each I would save and send to my phone it would hang forever. I had to close the browser and reopen then hit send again and it would work instantly. Obviously it saved it just would hang on the send part. The creator was running to slow to test in the browser. Had to test on the watch.

Hey guys - we’re looking into the slow loading this morning. Thanks for the report!

We’ve just realized a hotfix for the issues that came up recently. Let us know if you’re still seeing any weird issues.

Definitely better.

WORDDDDDDDDD… :+1: :+1: :+1:


Woo Hoo! My publish previews that resembled pancakes, are back to normal now. Whatever was fixed worked!

I can’t even use the creator right now. It’s taking a whole minute for every click I make. It took about 20 minutes just to update 3 objects by uploading to 3 layers.

That’s weird, it’s already fixed for me and for a bunch of other people. I assumed it would be fixed for everyone. Bad luck I guess

I guess. It’s going super slow today too, on my laptop and my phone.

I’m having an issue with Facer Creator today. Almost every time I try to rename a shape element, it kicks me out to the Facer homepage (if the design is saved - if I have any other changes, then when I try to rename an element it warns me about unsaved changes, as if it were about to kick me out, until I hit cancel). Weird.

Mine seems to be working well. Great to be getting back into Facer after a little break!