[KNOWN ISSUE] Step Counter issue on Fossil Gen 6 updated to WearOS 3

Hi all,

The issue:
As many of you have reported, we are seeing some issues with the step counter on the Fossil Gen 6 devices that have been updated to WearOS 3. On these watches, the default step counter complication provided by WearOS appears to no longer work, which affects Facer as well as all 3rd party watch faces using it.

Our team is investigating this issue with Google and Fossil. We are expecting this issue will be solved soon.

Known workaround:
The only known workaround at this point in time is for watch faces that allow the user to customize complications. For these faces, switching the step complication from the step counter provided by Google to the step counter provided by Fossil is known to fix the issue.

We will update this thread as we learn more and are hoping to have a fix for this soon. Thanks for your patience!


Any news on when a fix will be avaiable for fossil Gen6/wearos3 issue?

Also, if a work around is to use watch faces that allow the user to customize complications, how can i search and find these faces?


The update that released today seems to NOT have fixed the issue. Even after a reboot. Fossil Gen6 with WearOS 3

1 Like

Hi, I designed and am using my own watch face (on my Fossil Gen 6 watch), so how can I change the #ZSC# variable to get information from a Fossil complication instead of a Google one? Is there an alternate variable I can use, or maybe a setting to change?

The only way would be to have the Pro upgrade and use one of the “Customizable Complications”. Then on your watch link that complication to the Fossil app or Google app of your choice. But be forewarned, sometimes those will only act as a link and not display any information from some watch apps.

The step counter is working again at least on my fossil gen 6 glad that’s fixed for me I’m curious if other peoples step counter is as well

Hi, I’ve just learnt about Facer today and can report that none of the faces I’ve looked at have a working step counter for me on Gen 6 as of today.


1 Like

Hello I installed today the new update to my Fossil Gen 6.
And I have the Dial high n.23 pe…
And since then the temp display does not work and the Heart rate as well as Steps.
Can this be fixed please.
Thank you very much

Still no correction to wrong stats on every Facer face I’ve tried on my Pixel Watch. It’s not just steps. Calories burned and distance are wacky too. It also appears that the moon phases don’t make sense either. The moon here is waxing gibbous but watch face continues to show waxing crescent.

The designers work hard to create these cool faces. I should know. I’ve been one in my Fitbit days.

Hopefully, the March update will correct this. Does anyone have a Wear OS watch where these features work? I almost went with Samsung Galaxy 5 and now I regret not doing that.

1 Like

I have a Samsung Galaxy Watch 5 Pro and have no problems with steps or any of the other data points you mentioned. I learned years ago while working as a General Motors Service Technician, to never buy the first model year of any car just because of all the bugs they have. After the first year they have everything fixed and then it’s safe to purchase. Same goes with smart watches except you only need to wait 3 to 6 months or so. Software fixes are a lot faster than mechanical ones.

And that (Galaxy 5 Pro) is what I came very close to getting. Darn. Yes, I know Version 1.0 of anything is usually full of bugs. I would fire up the old Versa 4 - at least the faces all work properly, but unfortunately Google has pulled so many features and so a lot of other things do not. Only 3 to 6 months? Well, we’re almost there, so perhaps the March update will cure some of this stuff. Thanks.

1 Like

So when will the step counter work again? I uninstalled it, reset it, and it worked for a bit. Then i turned if off and charged it, and the step counter doesnt work again. I have a samsung galaxy 4 watch. Do i need to find another app?