My Step count not resetting

My watch is counting steps. But it dosent reset the count when its a new day. It just keep counting on. Any body know what to do to fix that ?

Have a fossil gen 6

That sounds like a Google WearOS or Fossil issue. I would contact Fossil and see what they can do. Facer only reads what the watch software tells it so that puts it outside the loop of information. I have a Galaxy Watch 5 with the newest WearOS 3.5 software and am not experiencing any issues like that. I also have an older Fossil Carlyle on WearOS 2 and its step count is resetting each day correctly.

Wait till it gets to 99,999…and see what happens. :smiley:

1 Like

in the fossil app its only showing todays steps.
Before i start using facer the count did reset every day. :roll_eyes:

1 Like

In that case you need to contact @Facer_Official at: They want you to include the watch brand and model number, the operating system version plus the Facer app version you have. Also include a detailed explanation of the issue you are having so they can investigate what might be going on.

Also try basics: turn watch off-on, reinstall Facer companion app…

I have the same problem… it goes down to zero in the morning in the clock, but on the facer display it can go on for days.
It’s a very enyoing problem!


I have a Fossil Gen6 and latest WearOs3

I was in contact with Fossil support. The issue is known and they are working on a fix.But that was a few weeks ago and still no solution in sight.

I mailed my problem to them yesterday tuesday 28/3)… Told them my problem, and got a reply from them that they should take a look at it.
Lets see how long its take… i think we must mail them often.

Do you know how long the problem has been? You have the same problem?

The problem has been since December.Forgot to mention that the counter resets if you have the watch on at midnight.

hi, sometimes it does, sometimes it doesn’t… now is my count up in 40000 step. Never been so many days. And I have it on… I load the watch at night and its on then.

Have the problem been solved for you?

But I was in contact with Facer… but I will contact Fossil to maybe.