NaN m problem. Please help

I have NaN m…can anyone help please? It was all okay on the watch but it has changed to this error code. When in the Facer creator, the watch face works perfectly. The watch is a Samsung Gear S3. Is it something to do with Samsung. Just weird to be working fine then stop. Thanks for your time.

Can you post the expression that is giving you the problem?

Hi, the text string is just from the basic elements and not changed:

(round(#ALT#)) $#UNITSYS#=IMPERIAL?ft:m$

Fingers crossed it’s something to do with that. Like I said it’s fine while being edited on facer/creator but not when it has been sent to the watch it shows the NaN m. It was fine but now shows that all my designs???

1 Like

@Facer_Official @mikeoday
I just tried it on my Gear S3 Frontier both the “ALT” and the “ATM” tags are nonfunctional for me. It’s been that way since they were introduced. I’m runing a MOTO X gen 4 with my Gear S3 and Facer 5.1.25_101589-(101589) with companion app

I suspect that that Samsung just won’t let the watch and Facer work with those two tags.

1 Like

@mrantisocialguy thanks! That’s helpful. We’ll look into that - it definitely worked in our tests, but maybe an OS update broke something.

1 Like


Speaking of updates my watch is running Samsung Software version R760XXU2ESF2/R760OXA2ESF2 and is the latest version.

1 Like

I’m not sure I can be much help as I don’t use these kinds of complex text expressions so I have no feel for what might be going wrong.

Having said that, I read somewhere that using “=” to test for equivalence works in Creator but does not always work with all operating systems. The recommendation was to always use “==” instead.

It’s the same with me. alt and atm work (display) correctly when designing on the FACER platform. After sending to the watch it does not work. Also Gear S3. I checked all my projects.

Hi Mike, I’ve tried == and it is still not working but thanks for trying buddy.

1 Like

If it helps, it happened after October 1, 2019. Earlier it was ok. I came to this after the release date of the Q83 V3 blue face. Initially the alt and atm data were displayed correctly.

Sorry to hear that buddy but glad to know it’s not something I’ve done wrong as new to this. Facer can hopefully find a fix.

Hi everyone, until @Facer_Official fix the issue, let me tell you how to workaround it. Just unistall Facer from your Samsung watch and reinstall it from Galaxy App in your phone. The enviromental data will be back when Facer reloads. Greetings!

1 Like