New custom face not updating

Howdy folks!

I created a new watch face here: Facer - Thousands of FREE watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more. I synced it to my Ticwatch Sport, then updated the face again. Now when I try to sync, all I get is the first version, not the updated one. I’ve tried removing the face from my watch, and reinstalling facer, but no luck. When I push it from either the web or my paired Galaxy S8, I still get the original version of the face.

Is this a known issue? Is there something special I need to do to force the watch to refresh?

Thanks in advance,

Hi @paulywogg99!

We did get some similar reports from other users recently and we are investigating. Can you try and explicitly save the updates to your face by clicking on the little floppy disk icon before trying to sync the face?

Thanks for the speedy reply.

On your suggestion, I re-edited my custom face, clicking the save icon before I clicked update. After that, I tried to push it to my watch again. No no change to the behavior.

Now I’m going to do a full device wipe, in the hope that the issue is with a cached version of the face on my watch. I also renamed the face on the creator page, further hoping to force the watch to realize it’s something new when I push the face to it again.

I’ll keep you posted on my progress. This’ll take a bit.

The updated face now shows up on my Ticwatch. I hope that helps your investigation.


Hi, I’ve the same issue right now. When I post an upgrade of existing faces it can be shown with the last mod in the browser but if I push it on my watch (Ticwatch Sport) I can see only the first version of it and not the last one… Any news?

Thank you in advance

Clicking the Save icon before you click update might be the key. I also renamed my face the last time I had this problem, and the issue was resolved. One or both of those things should do the trick.