New design not syncing to Pixel 2

Does anyone know why a face design would suddenly stop syncing with my Pixel 2? I hit the “send to watch” button, and it appears everything is processing and going. But then, nothing shows up on the watch. It went from working fine. Then I had to reboot my watch to get it to work. Now, nothing works. It works for other faces I have. It’s just this one. I tried copying it. But nope. The copy doesn’t send either. Any advice?

I prematurely published it, saved it to my favorites, and it loaded from the app on my watch just fine. Not the greatest workaround because you have to republish every time you want to see a change. But it’s better than nothing. Any insights into how to get the direct load to work again would be great.

I have the same issue on samsung pro 5 watch. Once a watch face has been published, syncing draft updates of a published face are hit and miss. Always syncs after you reboot watch though. If you accidently published it, you could duplicate it to make new copy and delete the published version maybe?

1 Like

The day after I posted, it worked. The next day it didn’t. The next day it did. Gaslighting by app I suppose.


Just buggy app. One day it will just work as it should…but that only really happens with apple eco system. I prefer android.