Pedometer Stuck at 0

My step counter on all Facer Watch Faces is not being counted on my Ticwatch E. If I go to my health app on the watch it shows how many steps I’ve walked through the day, but through the watch face it is stuck at 0, has been doing this for two days now. How can I fix? I already uninstalled and reinstalled the app on both my iPhone 6s and the ticwatch e itself. Really unsure as to why it wouldn’t count. I’ve also made sure the Bluetooth on both devices are connected as well. I can see how many steps I’ve walked on my phone as well just not on the watch faces themselves. Please help, thanks!

I have the same problem with my TicWatch Pro. No step counter, calories or heart rate. I also reinstalled it several times and tried different ways of rebuilding the watch, but with no success. Other watch faces and the default ones do show the steps.

I notice this is an old post, but it recently started happing for me, after the latest WearOS update. Before that it worked as expected.

Here is the announcement by Facer:


Thanks for that, I did try to search but that one didn’t pop up.

1 Like