Phone battery level not updating on watch face

Hi,

Recently updated to Tizen 3.0 on Gear S3 frontier, and had many of the same issues as other users. After installing, and re-installing both the Facer app, and the Facer Companion App several times, my watch face (TL Urbane-LED) started working correctly, except the phone battery level does not update. The phone battery level will either not appear, or it will appear when the watch face initially syncs with the phone, but not after. For example, if I choose one of the default Samsung watch faces, then choose my Facer watch face, the phone battery level is displayed as two dashes (–) and never updates, or it will display the current phone battery status, but that percentage will remain the same throughout the day, even after attempting to re-sync the watch face.

Help, please. This is frustrating!

Thanks

1 Like

Hi @steven.villano, @Facer_Official : I think this is a BUG, I’ve had the same issue with phone battery level indicators, % or dial type. I’m not sure whether this is a new issue caused by Tizen 3.0 as I had the same issue with the previous version of Tizen and the reading on the watch display rarely matches the % shown on your phone. 3.0 may have exacerbated the problem as the way the Facer companion receives push data from the phone may have been affected, We’ll need Facer Official Support to confirm this. Also do you use a Samsung phone, I ask because I don’t (one+ 5) and I wondered if this was the reason?

I do use a Samsung S8+, and prior to 3.0, all components were working perfectly. Phone battery level on the watch face corresponded exactly to the % listed when I opened my phone. Since the issues with the 3.0 update and the companion app, the only way I can get the battery level to update is to choose a default (Samsung) watch face, and then change back to the facer watch face, then after a few minutes, the battery will update to current levels…However, at times, if I have to restart the watch, the watch battery level will not display on the facer watch face. I just (again) uninstalled both the facer app, and companion app this morning, restarted both the watch and the phone, and then reinstalled both. We’ll see what happens. Happy New Year!!!

Install the last update from Samsung that will fix you problem en reduce the battery drain problem.
My face show now the battery of watch and phone

1 Like

Same here

I have reinstalled both the phone app and the watch app but still the battery indicator for the phone is not updated. the phone is also running the very latest updates.

I have done similar to everyone above but am still experiencing the phone battery level not updating. I am also receiving comments on my watch face that this is happening on many other S3 watches

1 Like

I found a fix by always keeping the watch face setting as Always On. I hate during this, as I sleep with my watch on and sometimes I activate unwanted options as I toss or turn. I prefer to keep my watch face in off mode. I sent an email to the company asking for this to be fixed.

Thanks for the report regarding the phone battery only updating properly if the watch has Always-On enabled! That will help us narrow down the issue and find a fix for it.

Is there a fix for this issue yet?

I’m having this issue on my Galaxy Watch. The phone battery never updates and is permanently “-%”. Would love to hear if this is something still being looked into.

Thanks!

I actually fixed this by going into phone settings -> apps -> facer and made sure all the permissions were enabled. Then I force closed facer and resynched watch. After that it started working!

2 Likes

Having this issue with FACER Only. Watchmaker phone battery works fine. I get it to work in Facer then for some reason it stops showing phone battery.
When I go to Settings/App/permissions the facer app is ALWAYS off on all permissions. I enable them and it works but never keeps working, Permisdsions always off on Sensor/ location/ and Storage

Is there a fix for this yet? I just created what I feel is my best design yet, but it includes phone battery, which was working at first but then quit. I tried enabling all permissions, and that didn’t help. I tried closing Facer and re-syncing, and that didn’t help. Then I switched to the default face and then back to Facer, and now the phone battery is displaying --%. I’m using the Galaxy Watch.

1 Like

Same here. Galaxy Watch, have made a new face that used to display the phone battery fine, but now is just --%. Seems like a facer issue that has been going on for over a year?

This worked for me!

This work a treat! Thanks very much.

if you have Wifi enabled on your mobile try switching it off. This instantly fixed my missing phone battery level display on my samsung galaxy watch

1 Like

Turning off Power Optimization of Facer solves the issue on my Huawei P20 Pro.

thanks, this worked for me, pocofone f1, galaxy watch s3 frontier. I also noticed that every day around 6pm snoopy pic, phone%, temp and humidity disappear, after 2-3 hours everything returns to normal.