Recent Watch Faces Freezes and Doesn’t Update


I am on the Samsung Gear SPORT. One day I was switching from one face to another from my ‘recents’ on my watch, the watch face loaded but when I triple tap to go back to the ‘recents’, the ‘current’ is still on the previous watch face, then I tried switching again to another watch face but the ‘current’ is still the same, but the watch face loads, it’s as if it’s frozen. I thought it was a glitch (that fixes by itself). Then I tried syncing another watch face from the app, but the ‘current’ was still stuck and the ‘recents’ didn’t change. So I reinstalled (from my watch) and then added back the watch faces, but after a day or so, when switching or adding a new one, it would still be stuck. This has been happening for over a week now. Anyone experiencing this issue too?

Welcome to the Facer Community ayoub.aisarraf
Did you try turning off completely your Watch and your mobile device and then on again? This sounds like something that happened to me recently and doing that sorted it out without any problems since.

Hi, I think I did do so, but I’ll do it again and tell you what happens.

Hi sorry for the late update, I turned both devices and waited a bit then turned them on again a lot of times but it’s still frozen :confused:

Then I have no idea sorry, maybe someone else here in the Community can help…

In that case I would delete all the stored Facer data from both your watch and phone. Next I would delete both the phone and watch companion apps. Then I would go and reinstall both apps fresh. It sounds like one of them, probably the companion app may be corrupted and causing you this issue. If all else fails contact @Facer_Official at: Submit a request – How can we help? or email them at: and let them know what kind of problem you are having.

1 Like

Thank you for helping here Mr Anti Social Sir :+1: