Renders perfectly in Creator, but not on target watch

Target is the TicWatch E2. In the Dim mode, the time is, well, dimmed and shows up perfectly in the emulator. However, on the watch itself, the time in Dim mode is full brightness, just like in the Active mode. The time is supposed to be dim red, just like the other text on the face.

Are you using conditional statements to achieve the effect you want?

If so, do you have brackets around the outside of the conditional statements, as in “($…? : $)” ?

The reason I ask is that I had a couple of Tickwatch owners tell me that one of my faces had an issue. It was solved for them by removing the outside brackets to just leave the $ symbols framing the expression. So, “($…?..:…$)” became “$…?:$”

1 Like

Let me check. I’m just using the Creator template and not yet advanced enough to use conditional statements. Was fascinated to read about your parrot menagerie!

1 Like

If you can activate the inspection mode and share the watchface link we’ll have a look and see if we can spot something.

1 Like

Ok, then some other issue…

As @orz0 said, if you can re-publish your watch with the insection mode turned on we can have a look.

And yes the birds … our cats are indoor only ( never been outside, except on a lead ) and the great number of birds that come to eat from the feeders drives them crazy :slight_smile:

The watch should be published now…

You can publish a bunch of parrot-themed faces! I used to have an African Grey and some conures… what fun.

1 Like

Thank you! It’s published. The emulator is terrific. I notice that the TicWatch C2 is available as a target in the emulator, but not the TicWatch E2…

Did you check the tick box for inspection mode? I can’t see the “rocket ship” inspection icon next to your watchface.

Yes, I ticked the inspection mode… the face is published in the lifestyle section… But let me double check…

Just published it again as SocialEyes 003 with Inspection mode ticked. Perhaps it takes a minute minutes for the new design to propagate?

Mmm, still no inspection mode. Not sure what is going on …

I click the Inspection mode and accept terms and conditions, then press the Update button, and away it goes… But in any event, here’s the problem. Perfect in the emulator, but the Time is at full brightness in the Dim mode on the target.

I just ordered a Fossil Sport and perhaps it will behave differently.

1 Like

It still no inspection mode, but i tried it on my ticwatch Express and it works, so, maybe is just that the newer ticwatch E2 is not already supported

1 Like

Ooops. Target-hardware-specific issues. Great! Yeah, the emulator doesn’t support the E2 yet…

But thanks for demonstrating that at least it works on the Express…

1 Like

It also works on my Samsung Galaxy Watch. Hopefully your new one will be ok.


Thank you all! This is a new area for me. We’re thinking of using these smartwatches as simple devices to give healthcare workers instructions on what to do next. Facer Creator is cross platform, which is fantastic, but of course some watches will be more equal than others…

1 Like