Samsung S3, Flaky Facer Watchface and Battery

Started using Facer several months ago and created a watch face the way I like it but this week I started having some odd issues. Have had people write me about the weather icon not working and all of a sudden it stopped working for me, too. I’d switch from the Facer watchface to a more generic one and then back to Facer and the weather icon still not showing. Power watch off and on and same but now the step count reset to zero and it wouldn’t register my steps. Could switch to a generic watchface and the steps were right, back to Facer and still zero. Restarted my phone and still the same and did have location services on as always.

The next day the weather icon was correct for some reason and it was recording my steps correctly. On a normal workday I go all day and when I got to bed and put my watch on my charger I’m still around 65%. But this day I tried to get my watch to turn on right after lunch and found it was off and wouldn’t turn on. Put it on the charger and the battery was at 0%. Charged it and seemed to be okay and same the next day (yesterday). It was 100% when I left for work this morning and just after lunch I get a message the watch battery was low and it was at 5%. I checked the battery usage and the top users were Samsung Health 8%, Notifications 6%, Weather 1% and Watchface 58%.

Not sure what’s going on but going to drop using the Facer watchface and see if the battery issue straightens out and if it does Facer is getting tossed to the weeds unless something is fixed.

Any suggestions???

Well, absolutely no help or suggestions and looks like I’m dumping the Facer app. Yesterday I tested with a stock watchface that is similar to the one I designed. Put the watch on and went to work and wore it all day and evening. Around 11:00 PM last night I checked and had 80% left on my battery and accessed the watch info tons of times. So today I put the Facer watchface on, barely even looked at it and yet by 11:00 AM (this morning) my battery was down to 50%. Ridiculous, can’t even make it thru the work day with the Facer watchface. Wasn’t like this not too long ago, did some update cause this incredible battery waste???

Fix this please, crazy to eat battery this fast.

Hi @veix57!

Sorry about that - can you share which version of Facer you have installed on your watch? Also, which exact model of the S3 do you own?

My mistake topping but I have an S2 not an S3. There version of Face I’m running is 4.5.11_87793-(87793)