Shape set to same colour as background appears lighter

I have a watch face set to use a dark green colour (#182017). A couple of circular shape layers are placed above this and they also have the same colour setting, with 100% opacity. I should not be able to see those shapes, but I can, as they are slightly lighter.

This looks like a bug in Facer Creator…

1 Like

Out of curiosity I just ran a test using #182017 as my color: background of Creator set to that green and a circle shape of the same color above it. On both Creator and synced to a GW4, the circle is not visible. I also created a PNG image image with the same solid green and placed it in between the circle and Creator’s background, with the same results. Take a look at this test (inspection is on) how is it showing up for you?

1 Like

If you are using the Creator Background Image Layer the Opacity is set at 47% by default for some reason. If this is something you know about I can only Applogise. I always use Image layers rather than Background or Background image layers to avoid the Management. :slightly_smiling_face:

Hi Kourosh,
I have only been using Facer Creator for 6 days, so I don’t know how to exploit ‘inspection’ for your test face design. However, I have run a similar test with nothing other than one circle shape using #182017 above a background of the same colour. Like you, I found that this worked fine. The circle shape was invisible.

There must be something in my face design that is causing my problem. I will have a go at deleting other elements one by one.

1 Like

Hi Russell,
I wasn’t using the Background Image layer in this case. The choice of built-in background images is rather limited, so if I wanted such a thing I would probably do as you do and add my own image layer.

Incidentally, the first watch face I created last week now no longer lets me add any of the built-in background images. I’ve added no background layer of my own to that face, so it looks like Facer Creator still contains a bug or two.

1 Like

So while you are in Creator working on the face You want to share a link to click on the share Icon and remember to switch the Inspection slider before you copy the link . then just paste it here .

I deleted every element from my watch face except for a couple of circular shapes and the identically coloured background. The shapes still appear slightly lighter than the background, as you should be able to see below (It’s more obvious if you use Ctrl+ to zoom into the browser window).

1 Like

Hard as I try I can not see what you are Seeing. Very strange link. Lots of adverts. I never see adverts normally as I paid for Facer Plus.
Have you tried having a Square ( Rectangular ) shape as a background. I still can not see an Inspectable link to your Work.

I originally used the ‘Embed’ link option to share that watch face. I have now replaced that with the ‘Direct Link’ option, which probably looks more familiar to you. The Inspect Mode switch was turned on.

The colour difference in the circular shapes is subtle and is more obvious if you zoom into the browser screen.

What does an inspectable link icon look like?

1 Like

You will see from my screenshots they are actually set as different colours .

This is very strange. Before I made my first post in this thread, I had checked multiple times that both the background colour and the circular shapes colour were both set to #182017. As you say, the background is now set at #151c14.

Perhaps I’m going senile…

1 Like

@david.anderson . David . Believe me stranger things go on . Part of the problem is the design is on a server 8 Thousand Miles away in my case . I have found that some things take a while to update . For me it is Stroke on Text . some times a tiny slip with the mouse while confirming position or Colour changes it . I mostly type my Colours and Positions in . I can get in a right pickle if I try to do something on my touch screen Tablet .
Did you notice that @kourosh set the colour of the Image layer Off Facer . That is an interesting test Proving that these Colours are a Standard . Which I was not sure about . So at the same time Thanks .

BTW @david.anderson To inspect a link that is posted here with the Direct Link Sharing .
Click on the Watch Face Name .
Then the little Rocket on the next page .

1 Like

It wasn’t blindingly obvious to a newbie like me how to view a Direct Link share in Facer Creator, so many thanks for that clarification, Russell :slightly_smiling_face:

1 Like

David . It is a Pleasure . It is great to be able to give back . None of this is blindingly obvious .
Here is a message I got back from Louis a few months ago now when they were not so busy . Talk about Dumb Question . If you are like me at all you will be asking the same Questions quite often .
Please keep coming back .

Now that I can see the inspectable face and see how there are 2 very close but different shades of green in the color assignment palette: I’ve been there many times myself, utterly frustrated and lost!

What I had done in a situation where a specific color dared to have more than one shade (usually because it’s late at night!), is to assign another specific and highly different color (bright red) to every single element in question. I’ve noticed that doing this will remove all “offending” shades from the color palette’s custom swatch. At that point I can start over and properly assign the one specific color I want on the appropriate elements, and at that point the color palette only shows the one proper color swatch.

1 Like

Nice Idea. As I was saying to @david.anderson I type them in . If I am getting in a real Pickle I write them down .

1 Like

I gave your idea a try Kourosh, but it was a very tedious job to change the colour assigned to all the elements in my rather complex primary face design. After doing this, I still had at least 4 redundant colours in the palette. I stepped through every element again but couldn’t find any I had missed.

For me at least, just tolerating the extra colours is the easiest option. If I ever hit a mismatched colour problem again, I will look harder for my own errors rather than blaming Facer Creator!