Shuffle not working on Samsung Gear S3 Frontier, Android 8.0.0

I checked the previous threads and it looks like this might have been solved in 2017, and so I would assume subsequent updates but I have the Samsung S3 Frontier the latest Facer on Andriod 8.0. I created a collection, dropped faces into that collection, and shuffled that collection. Phone gives me the confirmation and the first random face appears, but nothing after that. In settings, it’s set to 30 minutes between shuffle. But nothing. I’ve tried changing the settings then restarting the phone, restarting the watch, triple checking the settings. Still no shuffle.

Is the shuffling of collections only a premium option?

i literally am having the same issue. i have a gear s3 frontier with a galaxy s7 running android 8.0 and the shuffle will only change the first face then nothing. i have it set to shuffle every 5 minutes but nothing has happened in the past few hours. curious if the community ever found a resolution for this or if you ever heard anything back about it.