[Solved] Cannot show and edit my published watch faces

Hi Facer staff and to whom this may concern,

Two days ago I found a series of watch faces that I published (Military watch SL09172016 to SL09212016 total of 12 faces) cannot be displayed properly when clicking “view.” And when I want to edit those faces, the editing page never get loaded. I wonder if there is any problem about my design or if there is any new function of the editing page that might have caused this problem? In brief, this series of watch faces are all “not-displayable” nor editable. Please kindly help. Thanks!

example: Sunny Liao - Military watch SL091820162 - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

Hi @sunnyliao! Can you try loading those watchfaces again? We pushed a fix for this issue this morning, so they should be working normally now.

Hello @marcus, thanks for your help! Now those watch faces can be displayed properly and can be edited too. Thank you! I don’t know what had happened, but it’s great to get back on those watches and work some more on them! I really enjoy creating watch faces on facer. I wish this designing app to be more powerful and popular. Thanks! Sincerely.

Hello @Marcus, and @Facer_Official, thank you for your previous help. It was solved and I enjoyed accessing and editing my watch faces for about two days. However, today I encounter another new problem! I cannot edit any of my published watch faces. Whenever I click edit on one of my existing watch faces, within a minute or sooner, my browser will get crashed. This situation persists entire day. Could you help me on this? Thank you!

Update: FYI, I can normally inspect other’s work by clicking “see how it works.” However, when I go click edit for my watch faces, my browser will get crashed. This is really strange. Please kindly help. Thank you!

I’m having the same issue - anytime I try to bring up the editor for any watch face, the browser crashes. Thought it might be a compatibility issue, but I’ve tried Chrome, FireFox, and IE without luck.

I’m having the same issue too now. I created a couple of faces this morning and published one. Now when I go to edit one the face loads, but not the left-side panel. About 60 seconds later the browser tab crashes.

@sunnyliao @Rewind @Pugwash Hey guys, thanks for noticing this issue so quickly, it should be fixed now.

Hi @marcus, @system
Thank you for your help! I apologize for my late response because I intended to test it and then reply more profoundly. After your response, I have tested it for two days; it’s not crashing anymore (only 2 times that I consider very exceptional probably due to exceedingly long response time?)

I deeply appreciate that facer had done what it takes to prevent crashing. However, there is one situation perhaps important to update here. After your fix, I notice that editing/creating watch face becomes taking longer time even on adjusting or editing each single item. Whenever I must do any minor adjustment, in the “old version” platform, I could do whatever quickly until I save the change I made. However, on this new style platform (I have noticed this style must be a new editing platform), whatever tiny adjustment I make, it seems the platform would try to compile all layers of the face every single time. This way, it takes really much longer time for designers to design. So I hope this new platform editing style can be rearranged a little bit. Besides, it seems “impossible” for me to change the background color. So now I always have to put a “new shape” to provide different background color. Will this be adjusted as well?

Many thanks!

@sunnyliao Hi again! Are you still experiencing this issue?

Hi @marcus
Thank you for asking! Editing on each item on watch is still slow, but it won’t get crashed easily. Background color seems cannot be changed once I have chosen a color. So I have to add a new shape when I must change the background color. Thank you for following it up!

Thanks a lot!