Specific face not showing phone and watch battery

Hi everyone.
I recently got a new phone to match my galaxy watch, howbeit a watch face i used with my old phone called Pokemon Battle V3.0 has stopped showing phone and watch battery, showing a s blank. I have enabled all permissions and still nothing. Is there something i may be missing? Other watch faces show it just fine! I have attached a photo of the battery not showing.

1 Like

The phone battery issue is due to a Facer app update to 6.0.0 the current version is 6.0.1 and it’s not been fixed yet. I have no explanation for the watch battery issue.


When you say Galaxy Watch, do you mean one of the Tizen based watches or the recent Galaxy Watch 4?

The reason I ask is that I just tested the face above on my Galaxy Watch ( 1st series, which is Tizen based ) and my Android based Samsung phone and both the watch and phone battery meters are working correctly on my watch.

Hey mate
So my watch is the watch 4 classic and phone is S22, had a cheap ol oppo before which this worked fine with displaying my battery, only from switching. Tried uninstalling and trying again but always shows up blank.

I’ve looked through, the 3 default watch faces facer gives you works with battery, but downloaded ones won’t work. Any advice?

From other threads discussing this it looks like there is a know issue with the battery update on the GW4. So unless someone with the watch can figure out a work around then it may be necessary to wait for the fix to come out. Sorry I could not help.

The findings among different people / different watches don’t seem to be consistent…

I installed the Pokemon face mentioned above, on both My GW1 and GW4. On the GW1, both phone and watch battery readings were working fine-- until I restarted the watch, then phone battery stopped working and only watch battery was working. On the GW4 neither of them were working, even after a restart of the watch.

Then on the GW4 I switched back and forth among three of my own faces, and watch battery was showing fine (I don’t have phone battery on any of them). Then I switched back to the same Pokemon face, and neither were working again. No consistency…

Hello, I come to bring a temporary solution to troubleshoot the time that facer regulates the problem.
After several test I arrived at a result the problem will come from the phone application and not from the watch because on the watch I am always in version 6.0.1_106392 (galaxy watch 4) but I downgraded the phone version I passed in version 5.1.72_106101 for the phone (galaxy S21) it still available on galaxy store
And the my watch And my phone synchronizes again the battery of the phone all works perfectly as long as facer does not update the version of the galaxy store this temporary solution and valid .

Good day to all

Think well to block the automatic update in the play store for not that it updates the application facer