Step count not working

The step count does not seem to be working in many Facer watch faces that I have installed or ones I have created myself. The only ones I’ve been able to get to sync with my steps are from the Ticwatch built in menu. Please advise. Thanks!

1 Like

Hi @larist!

Sorry about that - are you seeing an inaccurate step count, or no step count at all? Can you also let us know which watch model you use, and share a link to the watch face you are testing?


I have a Ticwatch Pro.
On some watch faces I see an inaccurate step count that never changes, on others I see only a 0 where I should be accumulating steps
I have tried the following watch faces that have not synced with my step count:
Marauder’s Map 2

That’s the most recent one I’ve tried.
Just tried this watch face:

I get a 0 step count

Also - any watch faces I’ve created which incorporate a step count.

1 Like

I also have a similar issue. I have 2 watches. Gear S3 and Galaxy Watch4 classic. On the gear S3 all facer with a step count work. On the Watch4 Classic the step count shows 0 on the same watch face that works on the Gear S3. Check on the health stats for the Watch4 Classic the step count is active and always shows a count of steps but the facer step count is at Zero 0 . This must be an issue to the Watch4 Classic maybe as it works fine on the gear S3…oh yes tried about 20 facer watchfaces, all work on Gear S3 but none work on Watch4 classic. Any help welcome.

1 Like

I have the Galaxy watch 5 and have noticed since the OS update my step count most of the time doesn’t work.

1 Like

@dragnfli79 @facer7. Swap you face to a Native one . Then back to Facer . That wakes up the Data collection .

is that a bug with the watch software then ?
I will try that out and post update. Thanks