FACER Community

Step Count Problem

Hi,

While the step count function of the watch works normally, the arrow we added to that section does not work with the same code or #ZSC# code. I couldn’t solve the problem. I would be glad if you help.

Respects…

What arrow??

Please share link to the watchface and enable the inspector mode.

Test watch link:

Yellow arrow problem.

Thanks…

1 Like

Again, when you ask for help you have to enable inspector mode so other people can see what you’ve done.

You have to use math to make the arrow circle around depending on steps.
Here is a formula for full circle (add it to Rotation field) if the max steps are 10.000, starting at 0 degrees:
(#ZSC#*0.036)

If you want to make starting point at, let’s say, 30 degrees then use:
((#ZSC#*0.036)+30)

If the target steps are 5.000 then change 0.036 to 0.072
(2 x 0.036 = 0.072).
The point is: play with the math.

Try it, it should work.

2 Likes

Hi,

I’ve tried. It’s working. There are no problems at the moment.
Thank you for your help and suggestion. (Math will be used) :))

Respects…

1 Like

Hi,
The final edited version is published.
Problem solved. Thank you…
Respects…

1 Like

Glad you made it work.

Just ask, the Good Souls of this forum will always help. :innocent: :innocent: :innocent:

The best part of Facer is this community.

Happy to be a member of this community…