Step count wrong

The step count is wrong. It shows 8286 all the time now. This started 2 days ago. It is on all my Facer watch faces that I have a step count on. That would indicate something happened at Facer to change that?

Sigh…never mind. Turning the watch off then on fixed it. I think that’s the universal technology repair technique.

On Gear S3, when you turn the watch off, you go back to 0 steps and then it begins the count again until the next time the watch is reset. Has anyone found a way to show today’s steps (from midnight)? Thanks.

1 Like

Same issue on my Gear S3 Frontier, additionally, even when syncing from midnight on, the count is wrong, it shows considerably more steps on my Facer Watch Face then in S-Health.

Hi all! We are aware of an issue with step counts not resetting on Gear S2 and S3 and are currently looking into a fix. Thanks!

Thanks for letting us know that a fix is in the works. Is there also a fix for the phone’s battery information not showing up correctly (if at all) on the Gear S3?

You’re welcome! Regarding the phone battery issue, a fix is already in the pipeline and you should see an update for the app in the next couple of days for it. Cheers!

I’m sorry if this is the wrong place to ask 2 questions, but you’ve been so responsive thus far that I’d hate to lose your ear.

First, is there any way at this point for a particular item on a watch face to essentially be a link to something within the watch? For example, tapping on the steps count might take you to Health app within the watch. Or tapping on a weather item might take you to the weather app on the watch. Or touching the hours might take you to the alarm and touching the minutes might take you to the stopwatch. These are all examples, but I suspect you’ve got the idea.

Second, on the Gear S3, there are essentially 3 different “combinations” available for each watch face. One is the main watchface. Two is the always on watch face which is generally much more limited in what it shows. It can be black and white though I don’t think it has to be. Third is a watch face that is a dimmer version of #1. I’m not sure if it’s possible within the Gear environment to specify the third version. But if it is, is it possible to do that in Facer? Also, is it possible to specify a different set of colors for the always on watchface?

Again, thanks for your patience with these questions which are no longer really connected to step counting. For my reference, is there a specific topic dedicated to Samsung Gear S3 issues?

Any update? The step counter seems to be showing total steps instead of daily steps.

1 Like

Any updates on the step count.I am having issues with step count on my Gear S2.

Agreed… Its been about 2 months since we last heard that we are working on it. Any update?

Hi @alexander7567 and all - can you confirm you are running the latest version of the Facer companion app? v3.0.8 was released last week and should help with the step counter issue. Thanks!

I have an S2 Classic. I updated the app and it didn’t work. Then I uninstalled everything and started from scratch, and it still doesn’t work. Unless a factory reset is necessary, I think I’ve tried everything.

Nope. I’ve updated Facer to 3.1.1 on the phone, and the 3.0.8 Companion app for my watch (an S3 Classic.) And I’m still getting a zeroed out step count every time I change my watch face. SHealth says I’m at 260, but the watch face says 0.

Thought I’d update…I just updated to Facer 3.1.2 on my Samsung S7. I also updated my Facer Companion for Gear S2 & S3 to version 3.0.9.

Step counting still not working on my S2 Classic.

@jeffdelfield thanks for the report! We’re continuing to look into this and are going to release an update connecting to SHealth, when available. To help us make sure your issue is addressed, could you give more details? Is the step counter off by a few steps? wildly off? in the negatives? Does it ever fix itself?

Sorry about the delayed reply. I’ve been testing a few Facer watch faces on my Gear S2 Classic all weekend and this is what I can report.

The bad news is that when you initially download a watch face, it starts at zero (it does not read the current step count found on the watch). The good news is that the step count now starts at 0 steps each day and it is accurate to the number of steps S Health counts on my watch. For this alone, the app has been improved. Also, I could switch faces and the count would stay accurate. However, I tested powering the watch off and this is where the weirdness started. I thought that the app might start at 0 again, but it started with a negative number -57,000 (not this exact number it was negative fifty-seven thousand and change). This morning though, it fixed itself (I’m assuming this happened at midnight) and it was at 0 again.

If there is a way to connect directly to S Health, I believe that would solve the problem.

That’s what I know. Hope this helps.


Its weird but it was around the last post that my Moto 360 1st Gen stopped Displaying the count on the Pedometer its been at 0 for several days now . I have reset several time , re downloaded Android wear and facer still did not fix the problem . Anyone have a suggestion ?

Almost the very moment I posted this the problem fixed its self -_-

Also with the new version does not work on the counts steps S3 Frontier…