Step-counter not working on Huawei-Classic

This issue is now about 2 month already.

My Huawei-Watch doesn´t show steps anymore.

I tried already nearly everything, but nothing worked…

-Reinstalled whole Facer,
-Reinstalled Google fit
-Gave permission to all sensors
-Working with the newest software versions (watch and phone)

In normal watch faces (Huawei-Customs) there is no problem, Google fit has no problems either…

Any suggestions?



Thanks for the report! We’ll test on our Huawei devices.


@GAUSS we’re not able to reproduce this on our side with our Huawei. Can you shoot us an email at with all the info on when it started happening, what you’ve tried, etc? We’ll escalate internally and dig a bit deeper on that with you.


I will do if there isn´t any other chance.

First i will try a clean start (Resetting Smartwach, loading WearOS, loading newest Google fit and newest Facer Version).

Maybe it helps …

Status Update.

Yesterday i did a factory reset on the smartwatch, load all new, updated to all new versions (Facer smartwatch app, Iphone Facer app, Google fit…)


All is working now! :slight_smile:

But there is one issue in the IOS-App.

When you touch the sync button it syncs endlessly…