Steps from Google Fit not showing up

Starting a few days ago, my steps from Google Fit stopped showing up on my Huawei watch. I’m a runner and wear a Garmin to run, then switch to the Huawei for the rest of the day. Up until a few days ago, my Garmin steps (connected to Fit) would appear on my step count, but it has stopped.

Not sure if this is related, but at the same time, the progress bars that I have for steps starting going counterclockwise instead of clockwise. I fixed that by unchecking “reverse”.

I’m on
App version 5.1.44_102255.phone
Watch app version 5.1.44_102256
And Wear OS 2.35.0.318473698

I’m aware of a fix that Facer released with the last android app update, relating to progress bars in reverse. This is probably the cause for that issue.

For step count, have you checked that your app still has all the required permissions?

When I go into "Connected Apps in Fit, it lists Facer. It gives me the option to disconnect, but I’m not sure I know how to reconnect if I do that.

For me, the Windows solution usually does the trick. Reboot everything.

@cargo we made some recent changes to the way step counts are managed. Can you send us an email at facer-support@little-labs.com so we can investigate this with you? Cheers!

2 Likes

Just an update that Facer still doesn’t see Google Fit steps. The weird thing is that the Fit watchface sees them, and if i switch to a Pujie Black watchface, they show up there as well (they never used to, that’s why I switched to Facer). So other providers are able to “see” the steps, but just not Facer anymore.