Steps not working again 3rd time

HI as of a few days ago my steps counter is not working at all again… now even when i tripple tap the watch face to reload it still says zero… can you please help.

Hi! Which watch do you have?


Is there any update?


Hi I have not heard from anyone in a week now…

Same here. Huawei Watch 1. Couldn’t get steps count display to work on multiple watch faces. Google Fit is counting steps right.

All the steps on any face that I download or use that I created are not working for the last couple of weeks again please fix

Have the same issue as well since a couple of weeks with my Huawei Classic.

Hello, Can someone please help my steps tracker has not worked at all for a few weeks again… wont work on any watch face at all.

I have a Huawei Watch 2 paired with an iPhone 7 Plus and have the same issue. Have had the watch for 2 months. Steps worked fine initially but for the last 3 weeks they aren’t showing at all. Any help to sort this would be appreciated

I have a LG Urbane watch paired with a OnePlus 3 phone, and steps never worked for me. The count in Google Fit is updating correctly. I hope this information helps and you will be able to fix this issue.

1 Like

Any news on this they are still not working

Hi @mrsig226 - if you are referring to the recent issue with WearOS step counters, it is now fixed as of Facer 5.1.5. You can see more info at If you are still having issues, please contact us at