Steps not working

The steps don’t work on any face I try. I have a Samsung 4 Classic. The non facer watch faces do show the steps. On the Facer faces I get nothing. Weather seems to work.
What do I need to do?

You must give Facer all the permissions to access watch data. Go to settings > Apps > Permissions > Facer and make sure that Receive complication data and Sensors are both “Allowed”.


I don’t see sensors to allow. It is just location, nearby devices and storage that I see allowed then there is phone and camera that are not allowed. Please advise.

Try restarting. I was only asked about the “personal data” permission later. Hard to say where the mistake is.


Yes do like @petr.patocka said and restart your watch. If that fails you can contact @Facer_Official at: or email them at:

Thanks, the restart of the watch seems to have worked. Hopefully it won’t require that when I change faces. Thanks again.

I have made it a practice to shut my watches off whenever I charge them. It becomes an “automatic” restart, plus I think a lot of the instability in a watch comes from the act of charging it. I don’t have many issues anymore since I started doing it that way.

1 Like

Yes .restart watch or just wait 10 min…

Thank you! Restarting my Galaxy Classic 4 solved the issue with not reporting step counts! Everything was enabled but not working. Restarting fixed it.