Sunrise / Sunset time display: GW4

Has anyone else experienced issues with the Sunrise and Sunset not displaying on the Samsung GW4? I’ve seen a post relating to Suunto but not sure if this resolved the issue…Any thoughts welcome. Cheers MACH-1

1 Like

Tried, everything works for me. Restart?


Hey! Thanks for replying so quickly. Can I ask which codes you’re using for this? I’ve used “#WRH#:#WRmZ#” and “#WSh#:#WSmZ#”, but I’m getting messages from GW4 users letting me know it’s not showing… In the past I’d used #WRhZ#:#WRmZ# and #WSUNSETH24#:#WSmZ#. Knowing what you’ve applied would really help. Cheers.

I had someone with a Suunto having problems with a watch face I had made. I am still using the same codes with both my GW4 and GW4 Classic. They are working fine with it. It seems it’s only the older Suunto watches maybe because they are running an older version of WearOS. I also have a Fossil Carlyle for testing, and it works fine with all the coding for sunrise & set.

Here is what I’m using:

Sunrise 12h #WRh#:#WRmZ#
Sunrise 24h #WRHZ#:#WRmZ#
Sunset 12h #WSh#:#WSmZ#
Sunset 24h #WSUNSET24#

The above do not work correctly on the older Suunto except 24 sunset.
These below work on ALL watches, But the 12-hour versions forces display of AM or PM after the time:

12 Hour
Sunrise #WSUNRISE#
Sunset #WSUNSET#
24 Hour
Sunrise #WSUNRISE24#
Sunset #WSUNSET24#


Hi Mr A, Thanks for the input - appreciated. I did see the previous post (about the Sunnto) but I was hoping someone with a GW4 could confirm which versions work on it. Thanks again, really help full. Given #WSUNRISE# etc seems to work on everything I’ve used the separate elements #WSUNSETH#:#WSUNSETM# and #WSUNRISEH#:#WSUNRISEM# to avoid the AM/PM - which appears pretty obvious unless you live in Svalbard, Norway :wink: Thanks again. MACH-1


The only issue I can see doing it that way is people who use 24-hour time display will be seeing a 12-hour sunset. I have had complaints about that in the past and that is why I do my sun rise & set times the way I do. It cuts down on the complaints.

You could always add a third with the 24-hour sunset and use $#DTIMEFORMAT#==12?100:0$ & $#DTIMEFORMAT#==24?100:0$ in Opacity to filter the two.

2 Likes hijack this thread but this is why I could not get into coding

Seeing all this mixing of numbers and letters with symbols you guys call math makes my head explode.


1 Like

My Fossil Gen5 doesn’t show the short tags either, but Batwolf tested it on his Gen5 and they did, so it’s also maybe settings/permission related…


You’ve got me wondering. So, I went and set my Fossil Carlyle gen 5 to 24-hour mode in my phone. My watch faces with the “short tags” displayed fine. I then discovered that no matter what my phone is set at the Facer app selection of 12/24 overrides the phone’s setting on the watch. So, I’ve set it 12/24 on both the watch and phone and all four combinations of settings all displayed correctly on the watch. Fossil may have changed the watch software that runs on top of WearOS sometime between when your watch and Batwolf and my watches were made.