Syncing Faces Using Computer Broken Again!

I have been unable to sync faces using my computer and Facer Creator for the last two days. This issue seems to happen every month or two. Why does it keep breaking???

I have this too sometimes. Usually I’m able to fix it by going to the “my designs” on the phone app, sync from there and after that it often works again.

That’s what I did yesterday and synced my face. This morning when I tried it wasn’t even showing in my designs. I ended up using the webpage list I keep and clicking the link and opening it in Facer that way, then I could sync it.

very odd…

Sometimes this happens to me as well. What I usually do is go into the galaxy wearable app on my phone, re-sync my watch there, then it is able to connect to my PC again.

I’m dealing with a TicWatch and don’t have the Galaxy app on the phone that’s connected to it. It’s working right now, but the last two mornings when I upload a new face it won’t sync the new face.

Mine frequently stops syncing too. I find that if I wake my phone up, sometimes have to restart the Facer app, and it syncs and gets back to normal. Definitely a bit flaky!

It just makes it frustrating when you have a face draft that you have tested as far as you can in the creator and want to finish testing it in a real watch. Or like me I make sure that my test watch is running the last face I published so I can spot anything that I may have overlooked while I can still update it easily. It worked fine this morning though…until next time.

randomly I’ll try to sync and it won’t. I think I have always found that just trying a few more times will do it. I’ve always attributed this more to a watch connectivity issue than something based in the Facer system, but I could be wrong.