Temperature display stopped working

I have a Gear S3 and a watch face I made no longer shows the temperature. I updated the facer app on the watch last night and the update seems to have broken the weather. Any idea how to fix this? The watch is running 4.2.6.

1 Like


Is your watch connected to an iPhone or an Android device?


Can you check if the weather shows up in the preview of that same watch face in the phone app?

The weather shows up in the preview.

Can you try and switch from Facer to another watch face on your watch and back?

I tried switching to a couple different watch faces from the Samsung store and they all display the weather. I then switched back to Facer and tried several watch faces and the weather didn’t work on any of them.

Fixed it by removing Facer from watch and reinstalling it.

Now it is broke again and reloading Facer doesn’t fix it like the first time.

Same problem as sharpie described. Just updated Facer on Gear S3 with same results. Uninstalled, reinstalled. Booted watch and Android S6 phone. Made sure location was on, changed watch faces, etc. Dashes display for temperature and weather icon does not display. FYI. Thanks.

S8, Android and Gear S3 also here, and experiencing the same thing since updating to the latest Companion app.

I’m having the same issues, Pixel 2 and a S2 Classic.
I’ve tried everything mentioned above also, no luck.

Galaxy S5 and Gear S3. Tried changing wach faces. Tried remove and re-install of Facer on phone and on watch. No luck. Displayed data is correct in the app on my phone.

Just used the phone app to switch from temperature in F to temps in C. Sent watch face to phone. Then switched back from C to F. Sent watch face to phone.

Seems to be working at the moment.

Same problem after updating watch app earlier today. Galaxy S8 and Gear S3.

Tried switching temperature F and C and it didn’t fix for me.

Changing temperature from F to C, apply, send to watch did fix it for me. Changing back to F also was working. For me, doing one corrected all watch faces.

1 Like

Changing F to C doesn’t fix it for me…

I have the same issue. But the weather info doesn’t show properly on the preview either.

It’s showing a place called “Jackson’s Drift” and I’ve never seen or heard of it.

S3 Frontier / Galaxy S8

Problem still exists today. Weather shows up on preview within the app but remains blank on the watch.

Any official response we can expect?