Tetris 1989 Face not loading

Hi, I subscribed to Facer Premium a couple days ago just to use the Tetris 1989 Face but its not working at all on my Apple Watch Ultra. The Face load but the complications do not refresh, they look like empty holding places. I tried restarting my phone and my watch, I tried uninstalling Facer from my watch, I tried many things but nothing worked. I tried many steps in the help page here.

The weird thing is, other faces load fine. I have this issue only with the Tetris 1989 face.

I then contacted support but I receive one email per two days so its quite slow.

Anyone can help ?

I see others have posted on the watch face page as well. None are positive.
I have also had 1 person complain that my watch face would not load on an Apple Watch Ultra. I have not heard back, though. Seems the Ultra series may have issues with Facer on some occasions.

I can only advise to post on the watch face page as well, perhaps the creator will react.

Sorry, this may not be of much help, but plenty of other cool watch faces around.

1 Like

Ok thanks I think I will ask for a refund

1 Like