Ticwatch Pro 3 GPS Step Counter and Distance not working

I’ve got a Ticwatch Pro 3 GPS, have reinstalled Google Fit and Facer App but the step counter and distance never worked in any watchface loaded from Facer. When using other watchfaces from watchmaker or stand alone watchfaces, they all work fine.

It looks like it’s a cronic problem with these features in the app, as there are several threads pointing out this issue since 2019…Is there any WIP on this matter?

It sounds like you need to get help from @Facer_Official on that one, you can contact them at: Submit a request – How can we help? or email them at: facer-support@little-labs.com

I’ll try the request form than…Thanks!

For what it’s worth, those functions work fine on my TicWatch pro3 with Facer faces. Also, occasionally on any of my wear OS watches those counters do stop working, every time rebooting the watch fixes it. You’ve probably tried that, but if not…

Having the same problem with a Fossil gen 5. Just emailed support.

Go to Facer Settings - Complications - Tag Complications: set up appropriate Google Fit Stats for each item: distance, step count, calories

@bkossdnb Nope - no tag complication option on the updated facer watch app, so no way to tag complications (without rebuilding the face That is, but who wants to do that after paying for a premium subscription. Things should just ‘work’).