Time freezing on my facer watchfaces

Lately the time on my watch (samsung galaxy watch) has been freezing. It’ll be noon and my watch says is 8:54am. I have tried some watchfaces from the galaxy store and they seem to work fine. I uninstalled and reinstalled facer on my watch and it still happens. Should I try to uninstall and reinstall facer on my phone?

Any help would be appreciated before I give up on facer.


The only other suggestion other than what you have already tried (reinstall Facer on the watch) I can suggest is to restart the watch.
I can confirm that I do not experience this on my Samsung Galaxy Watch (42mm). Nor am I aware of this being a generic problem with Facer on the Galaxy Watch.

When not using Always On Display (my default), Facer faces do “jump” on wake up on the Galaxy Watch (perhaps on others too). I.e. the time the watch went to sleep is displayed briefly before going to the current time . However I have never seen the time “freeze” completely.

Hope you find and resolve the cause of this issue on your watch. :slightly_smiling_face:

I am experiencing the same thing on my Galaxy Watch. It seems like it started after the last update to Facer.

Hi all,

This issue is confirmed to be caused by a recent firmware update from Samsung on specific devices. It is not caused but a Facer update.

We’re working with Samsung to resolve the issue as soon as we can. Thanks for your patience!

1 Like

Hey Facer, any updates on the the freezing issue you’re trying to get worked out with Samsung?

1 Like

Same here. Wish they would fix it

Have any news? I cannot back to facer because this bug and I really miss you

Hi all,

Sorry to hear about your freeze issues on Tizen. We’ve started an official thread about the issue and will be sharing updates there moving forward. The thread also includes ways you can help us and Samsung identify the root cause. Thanks so much for your patience!

Link to the official thread: https://community.facer.io/t/known-issue-sporadic-facer-freeze-on-samsung-smartwatches