Total breakdown of the app

I have tried everything I can think of. Deleted the app of both phone and watch. The phone is a Samsung Galaxy Note 20 Ultra 5G, and the watch is Samsung Galaxy Watch 4 Classic 46mm. I’ve restarted both devices, deleted/reinstalled the app, and I STILL can’t get watch faces on my watch. It keeps saying that it’s waiting for the companion app. When it shows up on my watch screen, I tap “open”. It goes through this process like it’s loading, then goes back to the default watch face (which I hate). I’m at a complete loss on what to try next. Anyone have any suggestions?

1 Like

A Facer update has just been released - maybe unrelated but it could be good to try the latest version.

Then …some things to try ( sorry if you already know / have tried these ):

  • make sure your phone and watch operating systems are upto date
  • delete the Facer companion app from your watch
  • delete and re-install Facer on your phone
  • go to the Samsung {edit: not Gear, thanks @rob.fisk for pointing that out, my memory failed me } Galaxy app and select Facer as the watch face
  • open facer app, log in and go to settings and install the Facer companion app
  • wait a few minutes for everthing to complete and try to sync a face

If that does not work then you can contact the Facer support team at:

They will want to know all of your hardware and software versions and a detailed description of the problem.

1 Like

I got intp to the the loop of ‘continue on phone’ and each time went round in circles before getting it just right.
If I remember, as the final step, it does not then automatically select the facer app on the watch but leaves it on your last face in the selection list and you have to manually swipe to the facer icon to make it stick with facer facer or it’s one wor turn on the merrygoround…

1 Like

Hey Mike, where do you find out about release updates? I mean there’s a section on this forum, but if something has come out recently, I’m not seeing it there. It’s not on Facer news. Seems to me to be the two obvious places you might find something like that.

It came up in my Android phone after I did a check for updates in the Manage Apps section.


Also, tthis cut and paste method of sledge hammer fixing issues that involves strippiping the product cimpletely from 2 devices, using Samsung Gear (that has not existed for 2+ years) and selecting options rhat no longer exist in the wear app make me almost cry.

Don’t do a quick search and pick the first post without reading before a post.

Sorry Mike (not going to tag you but if this was 'Community engagement required) Zero effort was given to actually read, and understant the issue posted,
Insteast a 6-4 youear old post was copied and posted saying nuke it all and start again.

Wou;d not have solved the issue as it was one of information.

Sorry,. Got a bit rough there.Was the completetly inacurate instructions posted that got me, and how wrong it was. The comanion app is th phone app not yhe watch app… Just got me boiling.
(OK, I was the one completely wrong there. The rest was still out of date by several years but the intention was not to cause offence, just to highlight inaccuracies)

I am sorry I don’t know what you mean by cut and paste. Everything I wrote came from my memory - fallible as it is - and was a well intentioned effort to honestly help someone. With respect, an appropriate response might have been "sorry but there is a better way, try this instead …,. "


The Facer App is on the Phone, and the Companion App is what goes on the Watch.

1 Like