Unable to change the temperature unit

Big fan of Facer! The watch faces are awesome! However, i need some help please.
I am unable to change the temperature unit on any of the watchfaces… No matter what I do, it always shows in Fahrenheit. I want to change it to Celsius.

  • I am using Samsung Gear S3 with Galaxy Note 8 (all updated).
  • it is only the issue on Facer skins. On the original Samsung skins the temp. shows in Celsius.
  • On the watch, the weather app unit is set to °C
  • On the Gear app (phone), the weather unit is set to °C
  • On the phone weather app, the temp unit is set to °C
  • On the Facer app, the weather data temperature scale is set to °C
    Yet on every single Facer skin the temp is still shown in Fahrenheit! :unamused:
    Please advise! :pray:
    Thanks in advance

Hi @Asterix!

Can you 3x tap on your Facer watch face, then scroll all the way to the right? There should be a settings screen there to allow you to change the temperature format from F to C. Let me know if that works!

1 Like

Lol, could not possibly guess that there is another setting available with triple-tap… I thought that I tried all :sweat_smile:
Yes, that worked! Thank you very much!