Unable to create QR code

Hi, I have been trying to create a QR code for several days without success. Previously Facer was working on my Huawei Watch, but now I get the message SERVICE_NOT_AVAILABLE. I have factory reset watch and re-installed Facer and android wear multiple times. My Bluetooth and WiFi connections are working fine. I have the latest versions of Facer, Android wear and Playstore on the watch. I see people with the same issue on this forum without resolution. BTW Watchmaker is working fine. I even tried this with other apps uninstalled.

Hi @mdhirsh!

Sorry about that - this message indicates that the Google Play Services are not functional on your watch for some reason. They are needed by Facer for some features.

Can you let me know what type of watch you have and what version of WearOS is installed on it? Is that watch a China Edition by any chance?

Mine is a Huawei, non-Chinese version. I am running Wear OS version Google Play store finds and installs apps fine. My WiFi on the phone is working fine as well as the Bluetooth connection.

Its not working on iphone … i have tickwatch e misfit vapor moto 360 2nd edition after updating to wear os it doesnt work at all. Facer trying to figure it out.

Thanks! Can you check the version of the Google Play Services installed on your watch? You can find that in Apps > App Info > System Apps. It should look like this:

Sorry wish i could got so angry i sold all my wear watches. I sure hope you can fix the issue. Til then i went back to boring apple watch

Google Play Services is 14.7.99 (050300-223214910)
I hope that helps.

1 Like

You would think they would want to come up with a good fix. Apparently it’s affecting a large number of non-Apple watch users/ watches that use Android wear. It would also be good if Android wear would have all the functionality and ease of use the Apple watches do. They apparently do shine in terms of the variety of watch faces available.

Thanks for sharing - we’ll run some tests and see if that specific version of Google Play Services is the issue.

Anche io lo stesso problema su fossil q explorist

Hi there,

I have the exact same problem as described above, but there is a subtility…
When I tested with my friends Android phone, it worked perfectly, but it doesn’t work with my iPhone. I’m using an iPhone Xs Max under iOS 12.1, for the record.

@maruku so the exact same watch with the same version of WearOS worked when connected to an Android device, but stopped working when connected to an iPhone? On one the QR code appeared properly, and on another it didn’t?

That’s the exact same model phone I’m trying use it with. I’m not sure why the phone would make a difference since the watch has its own android apps loaded, and supposedly goes out via WiFi to get a scanable code.

Before I threw in the towel so to speak as the person above stated i dug out a old lg g2 android dinosaur and yes it worked. So what ever the issue is it is Iphone related. I would live this resolved. I have a gear s2 coming and if it does the same thing ill let you know. The s2 runs tizen

Oh, no, it’s not the same model. I’m using a Micael Kors Access Grayson (which basically is a Fossil Q if I remember correctly)
I don’t know if it’s the same version of WearOS, did not find it mentionned above, but it’s the last update, 2.1. The google play services version is 14.5.74

Ow, since you have the same iPhone, do you too struggle with getting internet through bluetooth ? it could be linked, because both the QR codes and internet over bluetooth are fixed with android, at least for me

Mine too is on Wear 2.17, and Play Services 14.7.99. The Bluetooth is occasionally unstable but readily reconnects. The WiFi occasionally disconnects, however it seems to be staying connected during attempted QR code retrieval. Amazingly, the Facer folks have remained relatively quiet on this major issue. I’m not sure if the code retrieval is via WiFi, or over Bluetooth via the phone. If it is via Bluetooth, that would explain why there might be differences between the Android and IOS platforms with watches still having essentially the same software.

We’re actively investigating it - so far we’ve only been able to reproduce this occasionally on WearOS devices connected to iPhones, and only if the WearOS device is NOT within range of the iPhone at the time of the first launch of Facer on the watch.

Does that seem like it may be a scenario that applies to those affected in this thread?

Every single time I’ve tried it was with the iPhone in my hands, so it doesn’t really apply

Sounds good - thanks for confirming. We’ll contact Google about this - the “Service Unavailable” error you are seeing comes from Google Play Services, not Facer.