Unable to get steps / kCal / distance data - all showing zero


I am using a Ticwatch Pro 3. None of the watch faces having steps /kCal/ distance data points are getting updated… All showing zero…

However, heart rate data and weather info showing up fine.

I already tried reinstalling Facer app on the watch as well as phone but doesn’t seem to work.


Please help…

I’m not sure how often Facer checks these discussions.
If no one replies here with advice you could raise a support request through the official channels:
To contact support see:
or send an email to:

Most likely they will want to know the full version numbers for your operating systems on phone and watch along with the various apps on the phone and watch.

Shame, I have exactly the same problem on the same watch that only started playing up a week or so ago. Did you get an answer ?

I don’t have that watch, but occasionally, not very often at all though, I’ll notice that my steps are showing 0. Coincidentally it happened today. I rebooted the watch and problem was fixed. If it’s a hardware issue and not a Facer issue I suppose it would explain why the uninstall/reinstall doesn’t fix it. But… maybe you already tried rebooting too?

I have this watch, and have had this problem now for several months. Rebooting etc hasn’t helped. Note the standard faces that come with the watch are fine, it is just Facer. A bit annoying as I have paid for premium!

Facer - Settings - Complications - Tag Complications: set up appropriate Google Fit Stats for each item.

I have a Fossil gen5 and haven’t had that issue. (YET) But I’m curious exactly how you set up Google Fit Stats for each one.

I’m curious as to where you see these settings. They are not in the watch app as they are on watchmaker.

I also have no steps issue - updated all the latest apps, reset, Uninstalled, cleared everything - still a no go.
If I can find a way to access tag complications again, I could try this.

I’m going to make a SWAG statement. (Scientific Wild Assumed Guess) You are the owner of a WearOS watch and it might even be a TicWatch. It seems like every time Google updates WearOS it breaks the step count in Facer. Something to do with linking to Google Fit. If you don’t have Google Fit on your watch I would go to the Google Play and download it. Give it and Facer all the permissions for any data on your watch and then restart both your phone and your watch. That tends to fix a lot of Facer problems. If it doesn’t you can contact @Facer_Official at: Submit a request – How can we help? or email them at: facer-support@little-labs.com