Unable to sync iOS + Gear S3

Since last night I am unable to sync any faces from the Facer iOS app. It immediately says “Unable to sync” on every face. I have the latest firmware and software on both my Gear S3 and iPhone. The watch and phone are communicating properly otherwise.

I’ve tried:

  • Changing faces from non Facer back to Facer
  • reconnecting watch to Facer iOS app
  • reconnecting watch to iPhone
  • uninistaling and reinstalling Facer iOS app
  • uninstalling and reinstalling Facer Gear S3 face
  • uninstalling and reinstalling Gear iOS app
  • turning off and on Gear and iPhone
  • hard resetting Gear S3

I don’t believe there is anything left to try. Is anyone else having issues on iOS?

Hi @grizgza,

Sorry about that! When you uninstall the app on your iPhone and go through the QR code scanning step - does that work okay and detects the QR code automatically?

Yes, QR code works fine. Looks like it connects OK immediately.

@grizgza can you share a screenshot of what that “Unable to sync” error looks like? Just want to make sure we look at the same thing on our side.

Thanks! We’re going to investigate this and get back to you!

Hi @grizgza - thanks for the report! This is now confirmed on our side and has been prioritized for fixing ASAP. Hopefully should be back to normal today. We’ll update this thread when it’s fixed!

1 Like

Hi @grizgza - this is now fixed. Can you try again? You may need to kill the app and restart it on your phone to make sure it works.

Just tested. Works great! Thank you

1 Like

Great to hear! Enjoy Facer!

Hi @Facer_Official
Was this fixed outside of an app update? I’ve had issues syncing faces from Facer for iOS to my S3 Frontier for a while and now the same with the new Galaxy Watch. Just upgraded the iPhone to an Xs Max and the issue persists.

After the exchange above, I tried again but still having difficulties with Facer faces not populating the watch.
If I restart the watch about 1 out of 3 times the face will populate, but not reliably.

@richpdcomm this was fixed outside of an app update, yes.

Is your watch on Wifi, or is it connected via bluetooth and your phone?

Currently Bluetooth. Previously I’ve tried a forced WiFi but not today. I will try that if you think it would be more reliable.

I’ve always had issues the iOS app and my Gear S3. I’ve found a technique that seems to be the most reliable for me. I open the Facer app first and before I try to sync a face, I open the Galaxy Watch app (let it sync) then go back to Facer and then sync faces. Works almost 100% of the time when I follow those steps. Not sure if it will work for you but might be worth a try. FYI- I use Bluetooth only

1 Like

@grizgza interesting tip! I think the root of the issue is that iOS kills the bluetooth connection between the phone and the watch very often and only the Galaxy Watch app can really re-establish it (which is why everything is fine again after you open that app). We’re planning to focus a lot of our efforts next week on the iOS app so we’ll look into that again for sure.

1 Like

FYI (only)

Same here (or similar) with my Samsung A8 (2018) phone, and either Samsung Gear Sport or Gear S3 Frontier. I always use Bluetooth, and have Wi-Fi disabled on watch(es).

I generally don’t get a warning / error message, just the watch does NOT receive the new watch face.

It it wont sync (about 10% of the time), I then have tried forcing the Facer app (on watch) to sync.

I find that opening the Facer app (on phone) before I open Bluetooth tends to stop it working (and syncing). I also have the same problem if I don’t wait 2-3 seconds (after Bluetooth acknowledges that watch paired/connected) before I start trying to sync.

However, just trying to sync another watchface (and another watchface) also works eventually. Then go back, and sync. the face you really wanted.

1 Like

FYI in case it helps you with the app troubleshooting. I tried to sync a face this morning but no luck as is the case lately. I was out driving 4 hours later and it appeared suddenly on the watch. Possibly a data flow issue or possibly something that changed with the connection away from the house without WiFi?

1 Like

Hi this comes up when I try and use the Facer webpage both iPhone and Apple Watch both updated I can get faces from
The app just not the website