Update 2.1 - No Long Syncing Weather

Ever since the 2.1 update, it’s not syncing weather data. If I manually switch between Yahoo Weather and Open Weather Map, it may resync but only once upon selecting the provider and never gain after. I’ve tried reinstalling the app, rebooting the phone and watch and the issue persists.

Phone: Nexus 6P running 6.0.1
Wear: LG G Watch running 6.0.1

For the record, that’s been happening to me long before 2.0 came out.

I’ve taken weather information out of my watch faces.

I have also been having the same issue.
Phone: OnePlus One 5.1.1
Wear: Moto 360 (2015) 6.0.1 (

Hey guys, thanks for the feedback!
Yahoo Weather is having some issues since last week, but OpenWeather should work. Can you confirm that it only seems to sync the weather when the provider is changed and never after that? We’ll have our team investigate ASAP if that’s the case.

It sometimes will sync upon changing providers but not always. It won’t ever sync again after automatically with either OpenWeather or Yahoo. It worked perfect before 2.1 (at least for me) and I used Yahoo Weather, even after they changed something with their API leading to some things getting broken. (Dashclock widget will just say no weather data available for example which I believe uses Yahoo Weather)

I’ve had this issue since Facer went to 2.0 and my Moto 360 Gen 2 when to the “Marshmallow” build of Android Wear.

Uninstalling the app and reinstalling it allows the weather to update once, but using Yahoo or OpenWeather no longer produces consistent updates.

Thanks guys! We’ll have our QA team investigate this immediately and update the thread as soon as an issue is identified. Thanks a lot for your feedback!

1 Like

I have this same problem since updating to 2.1. When I change from Open Weather to Yahoo then back it will sync, but not automatically.
Moto 360 Watch v.2 with 6.0.1

I’m new to the Facer community, and I have noticed this issue occuring on my watch face. Have there been any updates regarding weather not updating? I also have tried both Yahoo and Open Weather and as stated in another’s post, it only updates when I switch between the two services. Thanks!

New Facer customer. Very impressed with the Facer editing tools. Just picked up the Moto 360 and tried to create a weather watch face but none of the weather elements sync no matter who you use to sync with. It may sync once if I change sync provider. I can only assume by the age of the other posts that this issue has never been resolve. Come on mannn… Create a beautiful app but nothing works. It’s like going into a candy store but you can only look. Grrrrrrrrrrrr!! This app would be so cool if it worked. :frowning: Come on mannn… please fix.

1 Like

@Mr_T sorry to hear weather isn’t working for you! Can you share the URL to your watch face? We’ll inspect it and see if we can figure out what’s wrong.


Same problem here @Moto Sport.
No weather sync possible, doesn’t matter which provider.
The display is staticly frozen at 5°C.

Should there be any Improvements meanwhile ?

Views are increasing, but still no reply from Facer support :confused:

Why does my phones location have to be on to get weather info if I manually enter the location in the app?

Weather still not accurate in celsius mode on Fossil Wander Q. All other aspects of the various watch faces seem to be working properly.

Yeah, I just wanted to report that I too am having the same issue…in 2017! I won’t be purchasing any more faces until this is resolved.

I can get weather/temp. on the stock Moto 360 Gen 2 faces, but weather does not sync on the watchfaces that I design here. Am I doing something wrong when adding weather/temperature to my Facer watchface creations?
Members here have requested that I add weather, but I am reluctant to do more because it still does not seem to be working.

Example: Linlay Designs - Flag Day USA - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

Android Wear 2.0/Moto 360 Gen 2

Ive got weather issues, 2018! Whats the god damn problem? Facer watch and phone are on the highest version. Sometimes it works, sometimes not.