Watch Face not syncing

Just updated the gear software - when I update a watch which has had a design change I still get the old version of the watch face. Watch is Samsung Gear s3 mobile Samsung Galaxy 7 edge
Any suggestions or a fix? By the way the correct watch face shows on the mobile phone facer app.

Same issue and driving me mad.

Have deleted cache and data from watch and phone. Several times. Reinstalled facer on watch and phone. Twice each. Factory reset my watch! Still not right.

Mine is Misfit Vspor and the issue seems to be the app assuming there is nothing new to push to the watch.

You get the loading animation on the watch but the old version appears. I don’t know how this is possible after resetting, clearing cache etc.

I forgot to add that I have also duplicated a face, made changes to it and synced.

The watch receives the old copy of the face without the charges!

Hey guys!

Sorry about that - just to make sure we understand, the issue is that syncing one of your designs, and then trying to sync an updated version of that same design doesn’t work? Does that happen 100% of the time, or does it work as expected in some instances?


Yes. So you make a face. Happy and publish. Then realise an error.

Go back and rectify the error, republish, resync. Face loads, but it’s the old one.

Phone app and web page show update. But on sync you get the old one.

As said above. Plenty of deleting caches, apps, even resetting watch. Still seeing old version of face.

Even duplicating the face, making charges and renaming still show the old face.

I have just now fluked pushing the face with changes. What I did was radically change several things over the face.

In the past I had changed code, colours, layers activation. This time I did all of those things and more. Just as many changes as I could make while still having the design close to what I wanted. This time the sync pushed the changes.

Bear in mind also a full reinstall and 8 hours sleep (me, not the watch) so not sure the exact action that made the fix push.

Thanks for all the details! We’ll have our team try to reproduce this and update the post when we know more.

suggest having lots of layers and using some effects on images and text.

Graphically change glow to outline or one #tag# to #othertag# and see if the change shows on the app/webpage.

On sync, the change will not push to the watch. (loads as you’d expect, but once loaded the old one shows)

Have just recreated this myself.

Also when switching from one facer watch face to another the display flashes like crazy until you select a watch face. Can reproduce if need be. Only started doing this in last couple of weeks.

1 Like

I am noticing that if I save a face at all (even without publishing it or even if it is due to an auto save), then after I publish it, it will only sync the original saved, rough draft version to my watch. This is occurring even if I did not sync the face to my watch at all during drafting. As soon as that puppy saves in the creator I am doomed to not be able to sync the finished version. Every single watch face I have made today (June 23rd) has this issue.

Samsung Gear s3 watch
OnePlus 6 phone

Tried clearing caches and uninstalling/reinstalling app on all devices to no avail.

Also tried duplicating the face and immediately publishing, but I got the same issue. Was able to get ONE to sync properly by starting it from complete scratch and publishing it quickly before it could auto save.

Good thinking about auto save.

I just went back to a face that was not syncing and changed a few colours back and forth. Then allowed the designer to auto save. After that, I published and synced and it worked.

Please try if you get chance because if this works, maybe it’s easier for the team to bug fix.

Shout up if it does not work also, as maybe I got lucky.

So my issue is that I have to try to quickly load the watch face BEFORE it saves. Once it saves, I am never able to sync the final version to my watch. The only version I can sync to my watch is the version that was saved, but that is a watchface still in the middle of being built that doesnt yet have all of the conditionals or layers in place. The result is an animated watch face that isn’t animated or a watchface that is missing components (like the time). If I can manage to publish it before it saves it will work fine on my watch, but the second it saves I am doomed to never be able to sync any version of the watchface except where it was at in the process at the time of saving. It would seem they are syncing fine for other users, as some of them have been synced several times by other users. However, it won’t sync the final version to my watch, specifically.

I wonder if this is still being looked into?

1 Like

@Facer_Official Is this still being researched? I am still having this issue.

Yes - we’re still looking into this. Hopefully will have a fix this week!

I’ve had this issue too, I’m usually able to sync the proper version after a couple of days or upon re- installing Facer. Lately though I’ve had a few issues. Some of my faces now have a certain preview image, which is different to how it looks when you click it for the close up preview, which is also different to how it looks on the watch :smiley: all various saves/autosaves that occurred along the way while I was making them :smiley:

I have the issue still but have a somewhat successful workaround. Save right before publish.

I know some of you think that save is the enemy, but it can also be the solution, sometimes.

Worth a few tries

Also… try going to showcase mode (YouTube looking icon next to save icon on Creator page) - this forces an autosave. Then go back (four arrows pointing in icon). Then publish.

Seems to push the changes then.

Seems to work. Tried it in one watch face.

I am experiencing the exact same issue with the screen blinking like crazy. Gear S3 and Galaxy S8.

Hi I had the same issue : watchface not syncing after an edit and showing the unedited older verssion again on the watch. There wass an facer update where je can choose from previous synced faces on your watch by tapping 3 times. Probably the watch always takes the verssion from its intern memory buffer instead of the one you newly edited. If i go to the editor and make a copy of the newly edited face and sync that one…then mostly get the new version on the watch… so probably something in the filename-process.

There is a known issue about this affecting WearOS watches but I don’t think currently Tizen. I know they’re working on a fix. Should be soon. But in the meantime if you delete the face off the watch then resync it you’ll get the newest version of that face.