Watch face not updating when screen is off

I have a Galaxy Watch Active 2 and I created my first watch face with Facer. However the watch face does not update when the screen is off. It can take up to a couple of seconds for the time to update. This is a very annoying issue.

Is there something I could do about this? It will make me stop using Facer altogether and I was ready to go premium and all…

I have a Galaxy Watch Active 2 and a Gear S3 Frontier and they both do that, but only a quarter to half second not 2 seconds of lag. Though it is sometimes worse than other times. Using AOD mode will help on the lag, but your battery life will suffer. I’ve found that if you do turn on AOD mode make sure the Facer app on your watch uses the “Classic” not the “Dimmed” AOD mode. You can set it in the settings screen just past the last synced face to the right.

True, sometimes it is only half a second, sometimes its one or two. Noticeable either way.
AOD is not gonna work for me as I don’t want to drain the battery quite that fast and I prefer it off anyways but thanks for the suggestion.