Watch face suddenly stopped working

I have a Huawei Watch and I’ve been running a watch face I created for over a year. All of a sudden tonight the watch face stopped working. I have multiple versions and none of them work. All I get is the “Powered by Facer” screen on the watch. Factory watch faces work as do other watch faces from Facer. As a test I created another watch face in Creator using the basic analog template with no modification and it works fine as well.

Does anyone have any feedback or an idea of what’s going on? I can’t think of a reason that a watch face would suddenly stop working with no changes being made.


Hi @schriber! Can you share the link to your watch face? Can you also let us know which version of Facer you are running?

I have a face that I was using that also suddenly got screwy. Just installed it yesterday (worked fine all day), but after the update the dim mode was missing a few elements. Still looks fine in the app preview of dim, and resyncing the face hasn’t helped. I’m pretty annoyed, because I bought the aviator bundle specifically for this face.

@dramatdude can you share the link to this face? or its name?

The Facer version on the watch is 4.5.0_4736 and it’s 4.5.0_4735 on the phone. The face I’m using isn’t published. It’s something I have just for myself. Is there any way to share something that’s a draft in the designer?


Actually…Looks like it was a bug from the engine update. Its working fine now. But, just in case, here’s the url: GRR - AVIATOR II - Black edition - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

Having the same problem. Same version of the Facer app, updated earlier today, suddenly my custom watch face is just coming up ‘Powered by Facer’ on it. Coaldust - Cutie Mark Crusaders - watch face for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer

That’s the watch face I made. Uninstalled and reinstalled app, resynced watch face, restarted watch - nothing. Still says ‘Powered by Facer’ and nothing else.

Thanks for the reports everyone, we’ve released a new version of the engine this morning (4.5.1), after you’re able to update can you let us know if this resolves the issues? In our tests with the links you posted, all watches were working in the latest. If it’s still not working, please let us know which watch you are using and we’ll keep working on improving things. Cheers!

@Coaldust @dramatdude @schriber

Worked for me! Watch faces working again. Thanks for the prompt fix!

Unfortunately my watch face is still not working. Instead of sitting on the Facer logo it displays that for a moment and then just goes to black.

Is there any way to get the APK for the previous version until this is resolved?


@schriber can you open the face you are trying to use in the creator, and send me the url from your browser?

My watchface renders at a much lower quality than it did yesterday, making small text nearly impossible to read and the drop shadows no longer render at all. I’m on a moto 360 2014. Before the recent update, I’ve been using this watchface for around a year with no problems.

Of course! Here you go @Gavin

@schriber When did you create this face? It looks like it was created by our legacy creator from a some time ago, which uses different data than our current system. If you recreated the face today, it should work. In the meantime I’ll look into why our latest engine doesn’t support the old data system.

I’ve been using that face since the fall of 2016 @Gavin. It would be a major undertaking to recreate it so hopefully your team can figure something out. It worked perfectly until the other day. Thanks!

We’ll see what we can do, stay tuned! I’ve forwarded this request to our dev team to fix as soon as possible.

Thank you! Standing by.

I’m using a GS3 and my companion app is missing. How do I reload on my watch?

Hi @Gavin. The watch face is working again after the latest update but only partially. The date window no longer functions. Any feedback on fixing this with the new engine? Thanks!

To clarify… it renders properly in the web creator but not in Facer on the phone or on the watch. The date was working previously. Thanks!