Watch Faces freeze

So I’ve tried downloading multiple watches and even tried creating my own. I’ve deleted the app both on my gear s2 and off of my phone and it doesn’t help. I’m using an iphone x with the latest update. I can download the watches and everything works until the screen goes to sleep. Once that happens the nothing updates, the second hand is froze along with the time. If i switch to a different watch face from somewhere else everything works fine. I go back to a facer watch and it works again until the screen times out. Any suggestions? I appreciate any help.

Hi! Can you try enabling AOD mode on your S2 and see if it helps? We’re investigating a similar bug impacting S2 watches with AOD off.


So far that seems to be working. I know this is definitely drain my battery a lot faster with the display always turned on. Thank you for the temporary fix though.

Something else though i just noticed, when the screen dims, everything stops like it was doing before. Except this time, as soon as i do the wake gesture the time will update and both the manually second hard and the digital one start ticking again.The actually time keeps up though at least, which is an improvement.

Having the same issue since the update using same watch with my Samsung note 8. What’s AOD and how do I turn it off?

AOD is Always on display. It should be under Settings > Style > Watch always on


you will need to turn it on so that the screen doesn’t time out and go completely black. It fixed the issue for me, but i hope it’s temporary until they get a real fix because your battery will die a lot quicker since the screen never turns off. You can still have it dim to save some power.

1 Like

This is definitely temporary and will be fixed asap! Thanks for your patience, all!


Yes, I applied the always on screen and it seems to be working great so far! Thanks! Please update us when the real fix is done! Thanks!

1 Like

My watch face is doing the samething. I have the Samsung gear s2. When it goes to sleep the time freezes. It just started doing this in the past 2 weeks and nothing seems to work. When I use the samsung faces my watch works fine. I want to purchase a membership but with this happening im not so sure now.

Just to add my 2 cents, my watch is doing the same thing since the last update.
I have an S2 Gear paired to Galaxy S6 phone.

I have cleared cache and data, then uninstalled companion app and phone app.
I’ve done this multiple times. No luck.

I am able to get some relief with the AOD fix.
BUT! When the screen dims, it locks at the shown time until I shake the watch.
That basically makes my watch worthless as a time piece.

Also, I upgraded to Premium and now feel a bit ripped off.
Please fix this!

I am also using an S2 with a Galaxy S5, and am still encountering the same issue. I’m probably going to uninstall the app and wait until this gets fixed, because it’s extremely frustrating.

Interesting. 2 weeks since I posted my original request. No repy, no fix.
Which means no Facer for me, as I rely on my watch for correct time.

The AOD isn’t a real fix, especially when my battery dies halfway through the day.
Any idea when this will be fixed?

any update on when this issue will be fixed? Would really like to be able to actually use facer but I’m getting close to just deleting it and finding something that works.

@bishup02 @facer10 @gabeachen Hi guys, sorry for not updating this thread sooner. We have released a fix for this, which is now available on the Galaxy App store (v4.2.9).

thank you for the update.

So it seems this problem is still occurring. Since my watch faces freeze everytime my tick watch E dims. And I have version 4.6.4_98703. Any help please?

Hi @christopherfischer93! does it freeze completely and doesn’t reactivate when the watch face becomes active again? Or do you mean that the second hand stops when it enters dim mode?

Hi, I am getting this problem now since the most recent update, 5.1.1.

I have a Gear S2 and using face TACTICAL DTG THEMEABLE V5.

I have tried clearing cache, uninstalling/reinstalling with no luck. Once you apply the face it works fine but once the watch has been asleep for several minutes it doesn’t wake up and just shows an image of the time it went off.

I have tried setting AOD and this doesn’t help, it seems to be ok for a few minutes and then freezes up again and stops displaying completely, leaving a black screen for AOD.

Everything has been working fine with the app and this face up until the update in December.

I am having this same problem on my S3. Everything worked fine until the update. Now my watch face freezes so I can’t use my Facer App. Please fix this problem!