[WatchFace] Aviator Mk.1

As you can see in the thread below, at least one person is having problems with this face ( date, battery and steps numerals not displaying correctly ) and it would be great if you could let me know if the face has worked ok or not for you ( which model watch you have would be also good to know ).

My working theory at the moment is that my expressions ( based around the floor function ) are not playing nicely with his watch ( Huawei Watch W1 ).

It works ok in my watch, a Samsung Galaxy Watch.

Much appreciated,
Mike


Original post continues below


A new watch that sets out to display "the essential information presented in a clear, easy to read and Always On Display ( AOD ) watch face ".

A small feature, not immediately obvious, is the appearance of a red flag in the “fuel gauge” when the battery charge falls below 20%.

I would love to know what you think.

Cheers
Mike

4 Likes

Fine! Only one point: you should move the text „x100“ for steps in the upper field of the inner bezel. This will look better.

Greetings, GAUSS.

1 Like

Thanks Gauss, I think you may be right. I originally had an icon for steps in the top centre of the dial and the layout has become somewhat unbalanced when I removed it.

1 Like

Nice face, but I have 2 issues: in the photo I had 98% battery and should have 8537 steps… And I don’t know what the 08 means…

Mmm, very strange.

Thanks for the feedback - I will have to look into it.

The “08” should be the date - not sure why it is wrong. I assume it was the 28th when you took the photo - that means that there is a problem with the first digit.

Likewise for the other indicators - the dial hands look like they are in the right place but the numerals are wrong. For the battery, the first digit is for some reason not being displayed and for the steps, both digits are hidden.

It seems to work ok on my Samsung Galaxy watch. Currently shows,

with correct date, battery and steps displays.

The text for the 1st digit of the date is given by:

($(floor(#Dd#/10))>0?(floor(#Dd#/10)):$)

There are no other forumluas used. Transparency is always 100.

The text for the 1st digit of the battery level is:

(floor(#BLN#/10))

and Transparency is:

($#BLN#<100&&(floor(#BLN#/10))>0?100:0$)

Steps 1st digit

text: (floor(#ZSC#/1000))

and

Trans: ($#ZSC#>=1000?100:0$)

Steps 2nd digit:

text: (floor((#ZSC#%1000)/100))

and

Trans: ($#ZSC#>=100?100:0$)

Ok.

Given that the 1st digit of the date is showing “0” when it should be “2”, it would appear that the floor function might be returning an erroneous result.

Given that it works on my watch, I am not sure how to test it. Are you able to create a simple test watch to test the floor function. That is, just a text field with the text value set to, say, (floor(#Dd#/10))? This should show 2 on your watch if the date is twenty something.

I have uploaded an update with a few minor tweaks to the formulae. I am not sure if it will solve the problem. Please let me know.

Cheers
Mike

Hi again. I used again the face. The battery shows 23 instead of 22. Steps - none, 2 black boxes. And the date is 00 instead of 30. I use a Huawei Watch W1, all software updated.
Here is the new photo:


I hope it helps.

1 Like

Thanks for that.

Not sure what is going on. The battery, 22 instead of 23, might be just rounding down instead of up. You photo shows that the dial for steps is also not showing anything, whereas it seemed to show the correct value in you last image. I have not altered the hands expressions ( at least I did not do so on purpose - I will check ) so I am not sure why the dial would stop moving. As for the rest, I will keep looking into it. Do you think you will get a chance to create and load a test watch as I mentioned above - it may be the only way to confirm if the float function is working as expected on your watch.

Cheers
Mike

ps. With the steps, sorry, but I assume you have not just put you watch on :slight_smile: - I got extra concerned when I looked at my watch and saw that the hand was also on zero and the numerals blank! Until I realised that I had just put my watch on and I hand only done 90 odd steps :slight_smile: . The numerals display 1000’s and 100’s, so the display will be blank until the steps get over 100.

1 Like

Sorry, wrong edit above for the battery : it was 2 instead of 22. I will try again tomorrow.

1 Like

Mmm, still the same problem then. If I publish, just for a little while, a test watch with text fields for the various values, would you be able to load it and let me know the results?

Yes, no problem.

Here it is. Please let me know when you have downloaded it and I will remove it.

1 Like

Sorry, I wasn’t able to check the forum, so I missed the download. Maybe if we can choose an hour good for both sides? On my side now is 15:30. Thanks

Until then, I tested your new watchface (is great too!) and here is the result, in comparison with my daily watchface:


Thanks for that.

Sorry, we missed each other, I did not want to leave a test watch sitting in the published lists as it might bother people.

Here it is again.

Please let me know when you have it.

Cheers

Mike

Unfortunately I saw the email after midnight, so now I have 0 steps and the date is 1…

Ok, it looks like your watch behaves quite differently to my Samsung Galaxy

First of all, mine displays all the text - I don’t know why yours does not

WIth a battery level of 69, the third line, should display the result of ( floor ( #BLN#/10 ) ) = 6
yours shows 0

A little later in the day, you will see a value for steps but I suspect it will be the same as for battery level.

I am sorry, but your watch does not seem to be responding to the floor function in the expected way ( or maybe it is the fact that I am using the floor function in a text field ), I am not sure what else I can do. My design splits the 10’s and units into separate values so that I can display them in different windows. I will have to think about how else I might do that.

Thanks for trying out the test watch.

Cheers
Mike

Maybe Tizen is behaving differently to Android Wear?

Yes maybe. No one else has replied, so I don’t know if anyone else is having issues …