Watchfaces 30 minutes ahead of time on certain devices

Hi everyone,
I already have some watchface designs but am new to this forum.
Sorry if i’m not very active in the community, the sparetime I have I spend on making and sharing new designs.
Nice to meet you all though and hope some of you enjoy my work.

I was wondering if someone could help me out with an issue other users are having with my watches.
Some users are having issue with my watchfaces showing 30 min ahead of time on their device.
Strange thing is I can’t check it cause it works fine on my watch devices.

Problem probably has something to do with the code: (floor(#DUm#/10))
Has anyone else had this issue and is there another code I could use to retrieve the first digit of the minutes value?

Example of a watchface with this issue is:

Your help is much appreciated by me and other users.
Studio Vox

Hey Vox, welcome to the boards, you’ve got some nice work!

Your face is reading correctly for me here in the US est. Do you have any UTC codes in there that users might have accidentally hit? Could it be they’re just reading it wrong?

Hi Rator,
Thanks, nice to meet you and thanks for having a look.
Haven’t added any UTC codes cause I don’t even know how :smiley:
For me and a lot of other users the faces are working fine, guess for you its the same.
Its just a couple of users who have contacted me with the issue but this might be just 1% of the total users who have this issue.
I guess it remains a mystery for now :man_shrugging:

Yeah no problem, and it’s still reading correctly here btw. How many downloads do you have on it? If you’re getting like 1 out of 500 then it’s probably a user thing. I’ve had users say my face didn’t work but it was just displaying the stopwatch which they accidentally tapped.

Time correct on my side too.

Date gets cut off on my Samsung Galaxy Watch 42mm though…

1 Like

About 4000 so I guess the % with the issue is really low.
Ill just leave it as it is.
Guess we cant win them all.
Thanks again

1 Like

Hi mountain lion. Thanks for checking as well.
The face appears to be cropped differently on your watch.
I extended the box of the date so maybe this helps.

You are using UTC in that expression… do you know where your users are from with the 30min difference? There are some timezones in the world that are half an hour off instead of whole hours. Try #Dm# instead

Synced the face again; no change on my Galaxy Watch 42mm :slightly_frowning_face:

I uncheck the “fixed width” box for text fields as far as possible to avoid ‘clipping’ problems like this, but in this case the field might just be to close to the edge of the screen. You could try moving it up a bit.

Thanks, I changed the code so lets hope this works

Pushed it up a bit just now so lets hope this works too

Yes, that did the trick. Date showing as intended on my Galaxy Watch now (with the correct time). :slight_smile: