Weather always 0 F

I’ve tried restarting, allowing all permissions and reinstalling. On all faces, the temperature is 0, how can I fix this?

1 Like

Hi and welcome - try installing OpenWeather on your phone. Some people in this community have said that it helps. No doubt others here will help you in a moment.

  • check if you’ve given all permissions to Facer.

  • location must be ON on watch.


Exact same issue.

Have tried restarting the watch, changing units from metric and back. Nothing works. Happens on all Facer faces

Does nothing. Error persists

Turn location on in both your watch and your phone. If either is turned off, you will not have any weather. You also have to grant Facer permission to access location.

1 Like

Location is on both the phone and watch. Watch and phone restarted. Face removed and set again. Facer app itself removed and reinstalled. Open Weather app installed (as someone had mentioned to try that) - Still doesn’t work.

Happens with every facer watch face

Should note, weather works fine with the Samsung faces which come with the watch

Am going to try reset my watch to factory settings and try over when I get some time

Did a factory reset on the watch and it worked.

Though, do notice the weather icon (rain/sun… Etc) shows different to the weather app. Eg, it’s 10pm but says sunny. Weather app on phone just shows the moon?

The issue is the stock Facer weather icons are only for the daytime. Whenever I use weather icons, I make two layers one for daytime and one for nighttime with different images for the ones that show a sun instead of a moon. Then I use the correct expression to hide the one not needed and show the correct one for the time that it’s supposed to show.


Yes, it depends on the designer.
Some designers, like mrantisocialguy, will make different icons for day and night, most will not.

“Sunny” icon is in fact “clear sky”.

1 Like

Haha, you know what. I did think exactly that (sunny could just mean it’s clear)

Thanks for the clarification :slight_smile:

1 Like