Weather Complication Not Working

The weather complications (temp and/or humidity and/or current conditions) are not working for either of my Gauss watch faces on my Galaxy Watch 4 even though Facer app permissions are enabled on the watch.

1 Like

Welcome to the Facer Community pages!

DISCLAIMER: I’ve picked up this information from several different Facer Community posts, so this is just my overview of the issue.

First make sure you have all the permissions for Facer granted on both the watch and phone. You must have location turned on in both or the Facer watch app will not have any weather information.

Facer uses OpenWeather ( for their weather source. OpenWeather does not use your “exact” location (no matter what your watch says) and just gives the region wide weather which can be different from where you are now. Some have said that if you install the OpenWeather app on your phone, it will help the weather stay updated.

You have to make sure your phone is not set to use power management (Adaptive Battery) where it closes “unused” background apps, or at least exempt the Facer app from it.

Next, I’ve found that my weather updates more regularly if I open the Facer app 3 or 4 times during the day. There have been lots of times where I’ve looked at my watch and thought that the temperature was wrong, opened the Facer app, closed it and checked my watch and it be close to correct.

NOTE: I’m using an original Galaxy Watch, a Galaxy S3 Frontier, a Galaxy 4, and a Galaxy 4 Classic as my daily carry watches. I also use a Fossil Carlyle watch for testing my watch designs on. They all seem to have the same issue and cure.

These are my personal observations and are of course subjective: Your Mileage May Vary!

If all else fails, contact @Facer_Official at: or email them at:


Rusty, Yup, enabled location on both phone and watch, then turned watch off/on and weather complications are now working. Thanks for the quick - and accurate - reply!


Good deal. It’s amazing how watches and phones both act like an old Windows computer and start working right after a restart. :laughing: I’m glad you got it going!


Not just the Reboot. Some Sage Advice from a MAGician is often required.


Think we’re gonna need to pin this somewhere on the Facer home page.

1 Like

I’ve already posted my part of this as a separate post. Weather On Facer I tried to name it in a way that anyone who searches for weather it should come up pretty high on the search results. Now if we could only get people to use the search function to find it.


Maybe a Quick Start guide if there’s other common tips across watches? That said, as a new Facer customer, this was my first inquiry, and I did a search after posting the topic and found Rusty’s post.


Searching is how I find everything I want to know around here. Sometimes it’s like trying to drink from a fire hose, and other times nary a drop. On the rest of the internet Duck Duck Go and myself are best friends. :laughing:


Another thing you may want to add to the post if weather stops working, some watches turn off location on very low battery and forget to turn it back on when charged (happened to me recently on a Fossil Gen 6).
People might be confident they had location on and not realise it had been turned off in the background.
In addition, Location should be granted to the WearOS app on the phone for WearOS watches as I think it will try and use GPS from there if the watch does not have GPS.

Oh, and, if you have anything other than standard tags check your expressions.
I have been using a conversion from meters/second (who the hell knows how fast that is outside a physics lab) to MPH when the preference is metric. I’m in the UK, Europe may not like it but I don’t know how to make it do KPH on preference.
Anyway, I had been using
(round($#UNITSYS#=IMPERIAL?#WND#:(#WND#*2.237)$)) It worked in the creator and all previews but the watch always showed zero so I assumed it was part of the whole facer weather failure thing.

Turns out I needed to put the round statement inside the conditional, not outside to get it to work on the watch:

On another note, if you have a wind direction tally where the icon is pointed ^ by default, the correct wind direction expression is (#WNDD#+180). Wind Direction is supplied as where the wind is blowing from, not to.

There may be many garndmotheres out there wondering why I am trying to teach them how to suck eggs but maybe as many folks who will find this useful.

I do think a ‘How to do weather’ Tutorial could be good to collate all this.


I’m playing with settings. Turned location off on my Samsung Galaxy S7 several hours ago, and watch is still accurately reporting outside temperature. Will let my Galaxy 4 Classic battery run down and see what happens next.

Well, happy to report that after letting my G4’s battery run to 0% and recharging it, the location was still enabled…

1 Like

This is what I use for converting steps into miles and kilometers. I mashed two of TOMAJA’s expressions into one that reads either miles or km depending on the user selecting imperial or metric for unit of measure. The original post by @Tomas can be found HERE

This is my version based on his:

$#UNITSYS#==IMPERIAL?((round((#ZSC#*0.0476)))/100) ML:((round((#ZSC#*0.00762)))/10) KM$


I was converting meters per second into miles per hour for wind speed.

1 Like

Also. I do not believe the double equals to be neccessary going forward. It is being purged from all modern languages and so is probably only neccessary for a fraction of the oldest of watches.

1 Like

Sorry, I think the drugs the doctor has me on for my ear is affecting my brain instead.

Wind Speed

$#WM#=F?(round(#WND#)) MPH:(round(3.6*#WND#)) KPH$

Just remove the MPH and KPH if you don’t want the unit of measure.


But, facer only offers MPH on imperial and Meters/second on metric.
If someone has metric selected how do I know if they want MPH or KPH?
My formula does MPH on imperial or metric but there is no way to know if someone wants KPH as many metric people still use MPH for wind speed.

Nobody in the general public uses Meters a second.

1 Like

Ear infection? hate those feckers. They can get pretty bad. Or did you get hit in the ear by a dump truck?

1 Like

I agree, I’ve never heard of anyone that used meters/second either. All I can tell you is, I’ve been using the MPH / KPH now for over a year and have not had a single complaint about the metric reading. If people don’t gripe about it, it must be OK with them.

It started as an ear infection, but now they are telling me I have eustachian tube dysfunction. And what they are having me take for the pain is some seriously good stuff. It doesn’t hurt right now, but I’m not sure I would feel it if an airplane crashed into my head either. I’m hoping the steroids I’m taking fixes it so I can get off of the pain meds.


I remember when my migraines were at their worst and I was on ibuprofen, co-codomol and tramadol. Quite the cocktail.