Weather Not Updating on Moto 360v2

Hey all.

I have the Moto 360 v2 running on the Marshmallow build. It’s attached to a Droid Turbo running Lollipop. Facer app build is 2.0.3_471-(471).

The weather type and temperature has not updated over the past two weeks.

The tag list I’m using is: #WCCT# #WCT#°#WM#

It’s been stuck on "Light Rain Shower 50(Degree)F. I’ve tried switching from Yahoo Weather to Open as well as changing location and sync times. No change in any of those combinations/situations.

I’ve tried turning both the phone and watch off/on as well as remaking the entire watchface again from scratch. Help?

Just a thought. Can you check your Watch’s permissions and make sure that Facer did not somehow lose it location ability. Also you may want to verify that the facer app on your phone also have location permissions. I have the Moto 360 2nd Gen with the OnePlus one and I am able to get weather and location fine. One other note launch the facer app on your phone and verify that the set manual location is not set. That is all I could think of, I hope it is one of them.