What's with the quality and odd lines!

I’d like some opinions. I purchased a new Galaxy watch 4 classic. There is something crazy going on with it. Please compare the two pics I uploaded with one of the faces I created. The colored band is the Active 2 and the black band is the 4 classic. If you look closely at the 4 classic fonts, you’ll see fine white lines around many of the numbers (look especially at the 12 and 24 below and the 2 and 14, but it’s all over). These lines appear on every face that I put on the watch. The numbers on my Active 2 are clean.
This only happens with facer on my 4 classic. Stock Samsung faces are clear and crisp as are faces from watchmaker. Also the white outline around my DOW and day boxes comes out shifted on the 4 classic as you can see.

Yet another issue with the 4 classic is that sunrise and sunset do not appear correctly as on my creator - again they are in proper positions on my active.
I’d love your thoughts on this. I’ve already sent an email to the facer team.

I don’t have an answer, but I also have a similar situation happening: no such annoyance on my old GW1, but now that I just got a GW4, I keep seeing similar annoying lines around text on the GW4, with the very same faces. :face_with_raised_eyebrow:

Some specialty fonts do that on WearOS. I’ve noticed it on my GW4 “Active”, my GW4 Classic and my Fossil Carlyle test watch. The same fonts do not do the white lines on my Galaxy 1 watch using Tizen.

Ahhh, but what would make a rectangle shift position (like the one around me Date rectangles)? They both shifted to the left and up about 1x.

That I can’t answer. All I can say is I don’t have that issue with either of my GW watches. Maybe @Facer_Official would be interested in this since it’s a new watch and version of WearOS. You might contact @Facer_Official at: https://help.facer.io/hc/en-us/requests/new or email them at: facer-support@little-labs.com and let them know about your issue.

So I uploaded another of my creations “Day Tripper steel edition”. This shows how the “blued day area” is totally wrong on the 4 classic. The Active 2 shows it exactly how it should be (from sunrise to sunset), how it is on the creator. I tested this on another watch (non-watch 4) and it also worked fine. This is also pretty frustrating.

Regarding the lines…
Today I tried syncing a bunch of other people’s faces from Facer on my watch 4 and found that there were some fonts that did not have any white lines.
I wonder what is causing some fonts to do this. I have used stock Facer fonts and fonts from dafont.com. I wonder if there is a better-quality source that doesn’t have the line issue.

This happens with a handful of fonts; I get them from dafont too. Which one is it? So I can try it.

One way of eliminating this is by exporting the face and numbers as one image layer instead of using a bunch of text boxes.

@pandaKrusher I used Elliot Sans font off Dafont but most seem to give the white lines to some degree. I loaded some faces by other designers that did not show any lines but many did as well.

@pandaKrusher I don’t understand what you mean by :

Can you please explain?

If I’m interpreting the provided photos correctly - are you using text layers in the Facer editor to make the hour numbers on the face? A layer for “12,” another for “1”, etc.? If so, it might be useful to use an image editing program to create the face as you see fit and exporting it with all the text embedded as a single layer. It will certainly be less work in the long run. If you’re already doing this, forgive me, I don’t know what’s causing the white lines then lol


If I were to design all my watches in photoshop or illustrator and export to one layer on the face creator that would mean just using the facer creator as a publishing tool only. This is not figuring out the problem. I like Facer creator. I like being able to have control over each individual font and layer, being able to change color, size, opacity and move things around.
Do you design all your faces on other programs?

I wish @Facer_Official would drop in on this discussion and shed some light on what’s going on. Something is not right if Facer’s own fonts from inside the creator is causing this issue. That has to eliminate the font itself and make it either a Facer problem, a WearOS problem or a combination of the two.

@mrantisocialguy Yes, very frustrating. Have you synced my “Font test” (from my other post) to your watches? What do the fonts look like? If this is just on my watch, I’ll call Samsung and return it!

Not as yet, I will do so once I switch back to my GW4 this evening. Right now, I’m wearing my GW1. Though I might sync it on it as a comparison. I’ll let you know how my tests turnout.

UPDATE: I have synced it to my Galaxy 1st gen watch, my GW4 Classic and my Fossil Carlyle gen 5 test watch. It shows up on both the Fossil and my GW4, but not on the Tizen powered GW 1. Here is a screen shot of the GW4.


It is showing up on the same fonts and places in both the Fossil and GW4. I’m leaning towards it being a WearOS issue personally.

1 Like


It’s not on my Galaxy Active 2 either - very clear on that watch. It seems to be a problem with Facer on WearOS. All other faces on my watch 4 classic are fine, such as stock Samsung faces and even those from the watchmaker app.

Do you design all your faces on other programs?

Yea pretty much. This enables me to get the look exactly how I like. Text can have gradients, bevel and emboss, the kerning can be adjusted, custom drop shadows etc. Plus it prevents my head from exploding trying to manage 40+ text layers in the editor. I save the text elements for dynamic info that’s constantly updating like heart rate, date, and temperature. There’s nothing really wrong with the way you’re doing it but it’s a lot of work without any real benefit.

Out of nowhere the quality of all fonts have just improved. Has anyone else noticed this?
I’m not aware of any updates from either Facer or Samsung.


I saw this posted in another thread, says fonts are fixed on WearOS:


Ahhhh well that did it. I can really appreciate things now!